How do I get the Bootloader Menu with options?

EthanXP

New member
Oct 1, 2018
1
0
0
Visit site
Hi, i have a ZTE Conexis X1, i know its not a very popular or good phone. Over these past few days I have been trying to root my phone. I have tried those one tap root apps which I have completely lost fate in. Those things always fail. I learned that I can use a PC to toot my phone.

I learned a few things.
First, I need to unlock my bootloader.
After that I need to flash a recovery file(twrp).
Then I need to do some stuff with SuperSu which I have no idea about because I haven't got that far because of all the errors.

(BTW I did some research and found out my phone takes the same TWRP file as the ZTE Blade Axon)

I think the main problem is with my phone. The connection with my PC is alright. When I run 'adb devices' it picks my phone up. The drivers are all up to date. ADB and Fastboot files are all correct and run properly. The problem comes with my phone. When I type 'adb reboot bootloader' my phone does switch off and turns to a new screen. Then i typed "fastboot devices" and my device does show up! Normally, what is supposed to happen is there is supposed to be a picture of an android with his belly open and some options like clear cache and others(I know this from watching tutorials). This is not the case with my phone. Instead one of the screens that shows up when I normally power on my phone is displayed(like with"powered by android") and it just stays at that.

Originally I thought this is what fastboot looks like but notow I know this is not the case. Is my phone just trash? Did I miss a step? If you have an answer please explain in depth and further explain the unlocking of the bootloader in depth too please.

Thanks so much in advance!
I will respond immediately!
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
No, what's supposed to happen is what\s supposed to happen. You get a green Andy on its back with its stomach open, and a few lines of text after that (no menu).

If you can't get to that, something is wrong with your phone. I just copied this from a cmd window that's still open from flashing around a little yesterday (granted, on a different phone, but also one that has to have the bootloader open on to install TWRP):

adb reboot bootloader

That's what got it into the bootloader. Have you opened the developer menu in Settings (System/About phone/tap on build number 7 times, back key once, debug, look for the "unlock bootloader" switch and enable it)?

Then be careful - if there's a TWRP img file and a TWRP .zip for your phone, boot the .img file first, then (you'll be in TWRP, but only temporarily) use it to Install (in TWRP) the TWRP zip file. Then you'll have TWRP as your recovery. (Dont install the .img file by mistake - you'll have to install the boot.img file for your phone, if you can find one. If you can't you'll have to reflash the whole ROM. The .img file is just to get into TWRP so you can use it to install the .zip file.)
 

Forum statistics

Threads
943,031
Messages
6,917,002
Members
3,158,795
Latest member
pfrei