How do I stop having chromium webview open links, so they open in Chrome

A

AC Question

On my new Google pixel, I would like to make chrome the default browser for opening links, instead of webview. When opening links in apps like Facebook (with the in-app browser turned off) or Gmail (as is the case in the screenshot when I emailed myself a link to whichbrowser.net) it always goes to webview.

Under settings>apps>configure I have Chrome set to the default browser but the links still do not bring up chrome.
 

Clocks

Well-known member
Aug 27, 2010
2,009
18
0
Visit site
I haaaaaaaate this "feature". Stuff you open from Gmail or hangouts doesn't show in your history either because of this stupid webview thing. If anyone knows how to turn it off please share.
 

canawler

Well-known member
Dec 9, 2014
113
0
0
Visit site
Not sure about Facebook or Gmail but you can stop that behavior in Google searches. Google app > settings > accounts and privacy > open web pages in app > set to "using external browser"
 

anon(847090)

Well-known member
Jul 8, 2012
6,655
31
0
Visit site
On my new Google pixel, I would like to make chrome the default browser for opening links, instead of webview. When opening links in apps like Facebook (with the in-app browser turned off) or Gmail (as is the case in the screenshot when I emailed myself a link to whichbrowser.net) it always goes to webview.

Under settings>apps>configure I have Chrome set to the default browser but the links still do not bring up chrome.

Android N no longer uses chromium webview but used chrome webview for opening all links. technically its chrome but a dumb down version of chrome. Chromium webview is still there but its disabled. make sure you have not enabled the chromium webview and not selected chromium webview in developer option under "webview implementation"

to open facebook in chrome enable open in external browser in facebook settings
 

Trending Posts

Forum statistics

Threads
945,808
Messages
6,927,204
Members
3,159,972
Latest member
demasick