HTC one M8s stuck in bootloader


New member
Jul 18, 2017
Visit site
Has anyone found a fix for this?

Brief history, bought HTC one M8s off ebay. All ok until Android 6 OTA appeared and I wasn't able to update. Researched the the issue and it turned out that my phone had SuperSU & TWRP.

Downloaded RUU from Lalleman and managed to get phone back to stock, then OTA upgrade worked fine.

A while later the phone run out of puff during an upgrade and is now stuck in bootloader.

If I try to boot from SD with RUU I get error:
Device halted due to Large Image update fail!
Press <POWER> to reboot.
(I think this is because the version is older (RUU_M8_QL_UL_L50_SENSE60_Vodafone_UK_1.11.161.1_Radio_1.0.U20410.1@50408_15.00_016_F_release_430447_signed)

So I tried to unlock the phone using HTC unlock_code.img, followed instructions, select Yes and press power - phone reboots still, '*** RELOCKED ***'

So I'm at a loss, any ideas please?

Thank You

(bootloader) version: 0.5
(bootloader) version-bootloader:
(bootloader) version-baseband: 1.0.U20410.1@60201
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: xxxxxxxxxxxx
(bootloader) imei: xxxxxxxxxxxxxxx
(bootloader) imei2: Not Support
(bootloader) meid: 00000000000000
(bootloader) product: m8ql_ul
(bootloader) platform: hTCBmsm8939
(bootloader) modelid: 0PKV10000
(bootloader) cidnum: VODAP001
(bootloader) battery-status: good
(bootloader) battery-voltage: 0mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: 0b9a12e3
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
(bootloader) mfg-name: 0001
all: Done!
Execution time is 36(ms)