HTC One Won't boot/Boot Loop. No fix in sight.


AC Question

Hi all,

I'm not an expert on this stuff, and it seems more and more like I am screwed, but here is my situation. This morning my phone wouldn't turn on, sometimes it would show the power level, but mostly did nothing. When I got home from work it started going to the white splash screen when I tried to turn it on, which said "HTC one, quitely brilliant" and would hang there for like 5 mins and go black and repeat. I when into the hboot menu and tried just about everything, namely recovery and factory reset, and tried more and more of the options and none worked, they just restarted to the splash screen. I then connected it to my computer and installed the Android tool kits and such (I'm running Arch Linux if that is relevant) and started communicating with it via FastBoot. Upon extensive research it seemed (ans correct me if I am wrong) that my best bet is to apply an RUU. The problem is that everywhere says to run "fastboot oem rebootRUU" to get the device ready to apply the RUU, and you should see a silver htc logo appear on the screen. Well I have no such luck. Instead it just throws me back into the infinte loop until I manually shut down the phone. Is there any hope?

Here may be some more relevant info:
-The bootloader is LOCKED (it has *** LOCKED *** on the top of the HBOOT screen)
-It is S-ON
-The phone has never been rooted or tampered with in any way. I never even accessed the HBOOT screen prior to today.

If anybody could help, or let me know if the fix is impossible, it would be greatly appreciated.