Is SetCPU locking up your Bionic?

Rhuarc

Member
Sep 8, 2011
20
2
0
Visit site
I rooted my Bionic this morning, and installed SetCPU on it. The idea was that I wanted to under-clock the processor when the screen was off to help preserve battery life. The problem now is that as soon as SetCPU runs on boot-up the phone locks up and i have to do a battery pull. I fixed the problem by uninstalling the app really quickly before it started.

Has anyone else tried SetCPU on their Bionic? I am really hoping to be able to increase teh battery life by shutting things off (4G) or slowing things down (CPU) while the screen is turned off.

Thanks!
Rhuarc
 

Tyyyy

Well-known member
Jun 30, 2011
55
7
0
Visit site
Pretty sure you need access to the kernel, which we don't have, to be able to do anything with clock speed

Sent from my DROID BIONIC using Tapatalk
 

KTamez

Active member
Aug 25, 2011
39
0
0
Visit site
Yup, I underclocked like you, and when the screen was turned off (when I had it set to underclock), it wouldn't come back on. Battery Pulled, and Reboot, Uninstalled.
 

Rhuarc

Member
Sep 8, 2011
20
2
0
Visit site
Hmm, I don't know, but I seem to have gotten it working. It seems that some of the profiles that SetCPU tries to use don't work properly. I have no idea if it is correctly under clocking, but using the on-demand profile I have it under clocking to 300 when the screen is off. not sure if it is actually making much of a difference.
 

Rhuarc

Member
Sep 8, 2011
20
2
0
Visit site
I took it to 300. Which profile were you using? The moto profiles seemed to not work. I also had it set to start on boot when it was locking up. I have it set to not start on boot now as well.
 

KTamez

Active member
Aug 25, 2011
39
0
0
Visit site
Just re-installed. I was looking at overclock when the screen wasn't off, and changed it to ondemand, but on my profiles wer mothotplug. Seems alright now.

I verified it is working with Benchmark setting the main screen at 800 rather than 1k, benchmarked both ways and got the results as expected... All seems well now. Looking for every bit to help onthe battery, as I don't seem to have one of the "good" batteries some other people have.
 

Ewing33855

Well-known member
Sep 9, 2010
241
10
0
Visit site
I rooted my Bionic this morning, and installed SetCPU on it. The idea was that I wanted to under-clock the processor when the screen was off to help preserve battery life. The problem now is that as soon as SetCPU runs on boot-up the phone locks up and i have to do a battery pull. I fixed the problem by uninstalling the app really quickly before it started.

Has anyone else tried SetCPU on their Bionic? I am really hoping to be able to increase teh battery life by shutting things off (4G) or slowing things down (CPU) while the screen is turned off.

Thanks!
Rhuarc

Never had luck with set cpu. It did more harm than good IMO. I had it installed on my fascinate and charge and both phones didn't respond well. Maybe it was a samsung thing...lol

Sent from my DROID BIONIC using Tapatalk
 

chrislvn2888

New member
May 4, 2011
1
0
0
Visit site
Yeah i had the same happen to me when i put the cpu down to 300 mhz for min and max. also when i overclocked it i noticed with android overclock i can only get 1 ghz at best. anybody know how to bypass this so we can go up to to higher clcoks like 1.2 or 1.4. do they have the droid bionic bootstrap yet? is it coming out? Anyways give me a reply.
 

greydarrah

Well-known member
May 5, 2010
3,047
222
0
Visit site
Just re-installed. I was looking at overclock when the screen wasn't off, and changed it to ondemand, but on my profiles wer mothotplug. Seems alright now.

Sorry for the stupidity, but how are you getting to this "profile" (mothotplug) and is there one that did NOT work, and now you chose one that does work. Please elaborate.
 

greydarrah

Well-known member
May 5, 2010
3,047
222
0
Visit site
I got it working using the on demand setting, but I notice some stuttering when scrolling between my home screens. Does anyone else see this?
 

KTamez

Active member
Aug 25, 2011
39
0
0
Visit site
I got it working using the on demand setting, but I notice some stuttering when scrolling between my home screens. Does anyone else see this?

Nope, no issues at all here. All I really have it doing is humming at 300mhz, ondemand, with screen off (to try and save power). Can't overclock yet without more Develeopment work AFAIK.

Soounds like you figured out my post you quoted?
 

greydarrah

Well-known member
May 5, 2010
3,047
222
0
Visit site
Nope, no issues at all here. All I really have it doing is humming at 300mhz, ondemand, with screen off (to try and save power). Can't overclock yet without more Develeopment work AFAIK.

Soounds like you figured out my post you quoted?

I also have 300 for screen off and added 300 for over 122 degrees and 600 for under 30% battery. I guess I can try killing the other two parameters and see if it works well with the screen off only profile.

You are seeing smooth scrolling and no lockups with this profile, yes?
 

greydarrah

Well-known member
May 5, 2010
3,047
222
0
Visit site
Nope..still get a hesitation/stutter before moving from one home screen to the next. If you go to Advanced, what are your settings there? Mine are:

300000
95
0
0


Also, if you hit the menu key, then go to Device Selection (this happened automatically when you first started SetCPU up) Did you choose Autodetect Speeds or select something with Show Other Frequency Sets?
 

KTamez

Active member
Aug 25, 2011
39
0
0
Visit site
No problems. I had one random reboot a couple days ago with the screen off, noticesd with the phone sitting on my desk it was booting up (animation etc), but thats the only hiccup I've had in the nearly a week its been setup.
 

greydarrah

Well-known member
May 5, 2010
3,047
222
0
Visit site
No problems. I had one random reboot a couple days ago with the screen off, noticesd with the phone sitting on my desk it was booting up (animation etc), but thats the only hiccup I've had in the nearly a week its been setup.

Are your advanced settings the same as mine?
 

KTamez

Active member
Aug 25, 2011
39
0
0
Visit site
Nope..still get a hesitation/stutter before moving from one home screen to the next. If you go to Advanced, what are your settings there? Mine are:

300000
95
0
0


Also, if you hit the menu key, then go to Device Selection (this happened automatically when you first started SetCPU up) Did you choose Autodetect Speeds or select something with Show Other Frequency Sets?

All the Same.

I don't know what you have all running, how many apps you have on your screens etc, but I have almost pure apps on every screen and only a couple widgets running if that makes any difference.
 

KTamez

Active member
Aug 25, 2011
39
0
0
Visit site
Heres what I have,

Setup initiallly with autodetect

Main:Max 1k
Min 300
Scaling ondemand

Profiles:
Enabled - Notifications NOT Checked
In Call
600 Max
Priority 50
ondemand

Screen Off
300 Max
Priority 50
ondemand

Advanced(Factory Settings, as you posted above)
 

Forum statistics

Threads
943,924
Messages
6,920,668
Members
3,159,306
Latest member
xenomorf