is your Google maps slow?

aldo82

Well-known member
Jul 24, 2012
811
0
0
Visit site
Google maps on the m8 drives me nuts. There seems to be lag all the time when searching for places or plotting routes. So much so that I often press again thinking it hasn't worked. Anyone else find this? It seems to run awesome on my nexus 5, it's just the m8 that struggles...

Posted via the Android Central App
 

dmoss7

Well-known member
Apr 24, 2014
91
0
0
Visit site
I haven't found it to be slow, but I have found the navigation to be frustrating at times. I mainly get frustrated with it when it comes to interchanges and some exits on the freeway. Instead of "assuming" that I am going the right way and adjusting the route if I haven't, it "assumes" that I've gone the wrong way and starts the reroute calculation, then when it discovers that I actually went the correct way to begin with, it has to reroute again to the original path. It doesn't happen all the time, just about 30%-50% of the time. It gets frustrating when it happens with a short exit ramp and I have to wait for it to let me know which way I need to turn.
 

mcaspe1

Well-known member
Apr 23, 2010
268
17
18
Visit site
Google maps on the m8 drives me nuts. There seems to be lag all the time when searching for places or plotting routes. So much so that I often press again thinking it hasn't worked. Anyone else find this? It seems to run awesome on my nexus 5, it's just the m8 that struggles...

Posted via the Android Central App

Mine has a lag also. Very annoying.

Posted via the Android Central App
 

elvee68

Well-known member
Dec 19, 2010
410
0
0
Visit site
I don't have the lag issue but the blue dot direction drives me crazy. It properly hangs on the road I'm driving but will not point in the direction I am going. It just slowly spins. When I switch the compass mode, the whole map slowly spins. Navigation works fine.

Posted via the Android Central App
 

fireattack

New member
Oct 16, 2013
2
0
0
Visit site
I have same problem on my HTC ONE (m7). If I rollback to the stock version, it works pretty smooth. And I can use the newest on my tablet (n7 2013, with Lollipop sys) without major UI delay/lag. I guess something wrong on 4.4.x.
 

sitlet

Well-known member
May 16, 2010
176
0
0
Visit site
Mine lags like crazy. It started around the 4.4.4 update, but I'm not sure if that did it, or if an app update did it. But it's very annoying. Last night I was trying to quickly look up an address, and it took almost a minute to even load the search bar.
 

Daverk

Member
Apr 15, 2011
21
0
0
Visit site
Don't know what is causing the problem, it seems to be a combination of the application and os. Needs to fixed asap

Sent from my GT-P3110 using Tapatalk
 

aldo82

Well-known member
Jul 24, 2012
811
0
0
Visit site
Haven't used it much since upgrading to lollipop but initial impressions are that it seems much faster again so a 4.4.4 issue seems likely

Posted via the Android Central App
 

meeotch

New member
May 24, 2011
3
0
0
Visit site
Yes, I am experiencing the exact problem you mentioned. Started when I updated my phone to latest version of Android. It's horrible (Google Maps). I use Waze most of the time now, for that exact reason. It runs super smooth, just lacks some of the features.
 

mwake4goten

Well-known member
Jun 27, 2014
576
1
18
Visit site
One way to get around the slow issue is to roll back to the factory version, sure you will lose some extra features but if navigation is all you want then rolling back to factory version should do the trick with regard to lagging.
 

Trending Posts

Forum statistics

Threads
943,143
Messages
6,917,487
Members
3,158,838
Latest member
akbarramadhani12