Issues with Google Play Store HTC One

ankushhallan

New member
Aug 21, 2013
2
0
0
Visit site
Hey Guys,

I have a new HTC one factory unlocked version and since the past few days I am facing issues with Google Play store . When I am on my home WIFI and I open Google Play it will take me to the categories page and displays nothing else . I am able to search for installed apps on my phone but nothing else . It also doesnt display me the the Google Play home screen and other screens such as top new paid , top new free etc . But when I am on office WIFI and I unistall the updates on google play store and services it will work fine after auto update . But the moment I login to my home WIFI the same issue reoccurs . On my home WIFI all apps and other devices work fine but not Google Play

I raised the concern with google and below was the reply I received

If you're using a Google Apps account, ensure your domain administrator has the Google+ Hangouts function enabled for your account.

- Confirm that the app Google Authenticator is up to date - visit Google Play, then tap My Apps to see if you have an update available

- Ensure you have a strong connection, and contact your carrier or your internet service provider if you're not connected.

- Try signing into Google Talk, or Google+ Hangouts (your device should have one of these) using a network connection (2G, 3G or 4G) as well as with WiFi connection.

- If the problem persists only on WiFi, ensure firewalls are not blocking access to ports required for Google Play (TCP and UDP 5228).

- Make sure you have plenty of internal storage space available on the device (at least 20MB - you can check this by visiting Menu > Settings > Applications > Manage applications).

- Check that you have background data and auto sync enabled (visit Menu > Settings > Accounts & sync > Background data/Auto sync) - enabling background data and auto sync is required for Google+ Hangouts and Google Play to function.

If you've tried all of these steps and you're still having trouble using Google+ Hangouts, then I recommend you perform a factory data reset to resolve the issue. This will reset your device to its original state, so while your media content (photos, music, etc.) will not be deleted from the SD card, applications and their related data will be uninstalled.

Before the factory reset, make sure your contacts are synced to your Google account by signing into Gmail from a computer and verifying if your contacts appear there. If your contacts are not synced, then I recommend updating your sync settings at Settings > Accounts and Sync and choosing either AutoSync or touching the account you would like to sync and choosing "Sync Contacts." You may also want to backup any important application data and/or settings by navigating to Settings > Privacy and selecting "Backup my data'"and "Automatic restore."

To perform the factory reset:

1) Go to Home > Menu > Settings > Privacy (could also be under Backup & reset, Security or Phone Settings, depending on the device)
2) Press Factory data reset
3) Press Reset phone

After you perform the factory reset, make sure you sign into your device with the same primary Google Account you were using before.

My issue still persists and I also dont know how to check whether port 5228 is available for google play or not on my home WIFI . I have not done a factory reset yet

Any inputs are appreciated .
 

Scott Kenyon

Well-known member
Apr 2, 2011
2,060
1
0
Visit site
You'll have to forward the port on your router if it is blocked. Refer to your router's owner's manual for the correct process on how to do that. Let us know if it works.
 

ajua

Well-known member
Sep 23, 2012
363
0
0
Visit site
Do you have the latest version of Google Play? It's 4.3.11. If not, you can install it manually downloading from Android Police site or let me know and I will upload it somewhere.

Try the port thing as well to see it solves the problem.
 

ankushhallan

New member
Aug 21, 2013
2
0
0
Visit site
Thanks for the reply. Yes i have latest Google play store . I am trying for port forwarding on my router but no luck as if now.

Sent from my HTC One using AC Forums mobile app
 

JPancrazio

New member
Aug 24, 2013
1
0
0
Visit site
Wanted to add my 2 cents.. I have an Droid 4 / Nexus 7 (2012) and have this EXACT same issue.. Just got off phone with play support, and they mentioned that lots of people are starting to have this issue as well.. I tried a couple of the "fixes" and nothing helped.. i dont want to have to factory reset my device ... I do notice IF i search via chrome for an app , then goto to it's page on play, install it from there and choose chrome to open it, it will install fine .. And the port fowarding option just doesnt make sense. I am the admin @ work , and my devices work from that network , and i can say i dont have ports fowarded .. Once again .. just adding my 2 cents..