LG urbane 2 phone calls without sim

Osirisman

New member
Dec 21, 2016
2
0
0
Visit site
That's what I thought.
Any idea of how to set it up properly? I have been trying but I when I try to make a phone call from the watch its show a screen "Voice calling info. Connecting to server. Please try again."
When I call people from my phone the watch doesn't show an active call and I am also not getting Text message notifications.
Any thoughts?
 

foxbat121

Well-known member
Jan 28, 2011
1,729
2
38
Visit site
Do a search here for how to enable 'Phone Audio' under BT settings. You will have to disable NumberSync or Number Share feature depending on which version of watch you have for the 'Phone audio' option to show up.
 

Latest posts

Trending Posts

Forum statistics

Threads
943,742
Messages
6,919,885
Members
3,159,204
Latest member
franzmorais