• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Massive Storage not working in T813, computer does not detect device


AC Question

Hello fellas,

I have a problem with my brand new T813 running the latest official firmware available (Android 7).

Massive storage is not working, my computer running Windows 10 with updated samsung drivers has failed to detect it. The device charges, but I am unable to modify the usb options, regardless the choice MTP always remain.

I have tried with three different cables, all of them work fine with my S7, the computer never detects the device, eventhough it's charging. This means it is not a problem with the device's micro usb port. I have the latest drivers, and I have also tried with all usb ports. None of them seemed to do the trick.

The computer has faulty usb 3 drivers, ever since I have installed Windows 10, the speed is not what used to be with the previous configuration. I have the same drivers, I don't understand what's wrong.

Any help would be appreciated, I have tried most solutions mentioned on this community and they didn't work. I can't flash the device because it is never detected. The problem still persists after a reestablishment via the menu.

Download mode shows


Retired Moderator
May 23, 2010
Uninstall the drivers then reinstall. Also, try any other USB connections on the device and see if that helps. Worst case scenario is that you can try using a WiFi tether option to transfer files/view the contents on your devices storage. AirDroid is a wonderful option: https://forums.androidcentral.com/e...s/details?id=com.sand.airdroid&token=DuMhs5Bn

I know is shouldn't be your only option, but sometimes it's the best and you'll not have to fiddle with drivers/cables. My guess is that something within the computer settings or software is preventing the device from being visible. And I'm not sure that Kies will be the solution to your fix either, but it's worth a try: Samsung Kies, Free Download Kies 3, Latest PC Suite, Mobile Software, Window 7 PC