MMS unable to Download?

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
:confused:

I tried searching for an answer for this but had no luck.

Since the update I have been experiencing an almost 100 percent failure when I receive an MMS. Before the update it would happen randomly but very seldom. I get most of my MMS when I am at work so my wifi is definately turned off at the time. At home I bounce back and forth from wifi on and off so there is no telling during those times.

Has anyone else experienced this and if so is there a solution out there that I am just missing?

Any help would be appreciated.

Oh and I am not rooted.

thanks
snatcher
 

Quis89

Q&A Team
Oct 15, 2009
592
50
0
Visit site
I noticed I couldnt send MMS after the update. I did a soft reset on the phone and gave it a day and its been working fine ever since. Dont know why it wasnt working but I'm glad it came back around, lol.
 

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
I have tried resetting a few times but doesn't seem to work. I still can't receive MMS on either the native messaging program or Handcent. I will get some random notifications at times as well with both. They will come up from one of my normal contacts but when I click on it to view it, it will change to a random series of numbers or say anonymous. My regular texts are fine though, only MMS have the problem.
 

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
Am I really the only person not receiving their mms messages? It is pretty much 100% of all mms can not be downloaded using either native messaging app or handcent. I have received messages from multiple contacts from different carriers and all fail.
 

Jerry Hildenbrand

Space Cowboy
Staff member
Oct 11, 2009
5,569
2,797
113
Visit site
Update your profile menu--settings--about phone--system updates--update profile.
reboot the phone
call sprint, tell them you do have the latest profile for your phone and they need to disable sms/mms, send one to verify it's blocked, then enable sms/mms, then verify again.

This is what was done to fix a hero here after the update, and it has worked fine since.
 

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
Talked to Sprint and of.course they said they couldn't disable myessgaing and re enable it so I just backed upy info and did a hard reset and everything sea to ne ok so far
 

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
FYI

Started happening again after a day or two. Don't know what else to do.

"download of message ... was unsuccessful" is getting old every time I get a message.
 

Jerry Hildenbrand

Space Cowboy
Staff member
Oct 11, 2009
5,569
2,797
113
Visit site
What I would suggest -
Take it to your local Sprint store.
Make the Tech send you several MMS messages, and let him see they don't open.
They replace the phone.
When it happens again, take that one in as well.
Raise a little fuss, get a nice credit (they love to give credits to shut customers up), then explain that it happens on 2 phones, therefore it's a PROBLEM ON THEIR END. Politely tell them they could have saved the cost of the new phone + shipping + your time and trouble + the amount (if any) of credit you got if the tech had listened to something ANOTHER TECH figured out already for many others.

I love Sprint. Usually everything works. But they are stubborn as hell when it comes to troubleshooting. Their techs refuse to think outside of their box. In a case like yours, it's simply unacceptable.
 

repinphilly247

Well-known member
Nov 20, 2009
69
2
0
Visit site
Thanks for the advice, I will try this weekend and see how it goes.
Thanks again.

Hey, I'm fairly new to the forums (only 2 posts).

I have the same problems as you with the MMS. It was working great up until the update. Now I can only send MMS but when I get one it says download unsuccessful. I was on the phone with Sprint for an hr and a half and they couldn't fix it so they told me to try a hard reset or take it to a tech. I don't really want go through the time of a hard reset to get everything back to where it was. I was just wondering if you resolved your problem and how did you do it?
 

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
Still not resolved, but I've been pretty busy lately so I have nor really tried to deal with it again yet. I have some vacation coming up so I will try again then. Yeah don't bother with the hard reset all you will do is lose everything and have to do all the work to get it back. I will update once I know more.
snatcher
 

tonksnatcher

Active member
Nov 23, 2009
31
0
0
Visit site
Still not resolved, but I've been pretty busy lately so I have nor really tried to deal with it again yet. I have some vacation coming up so I will try again then. Yeah don't bother with the hard reset all you will do is lose everything and have to do all the work to get it back. I will update once I know more.
snatcher
 

soulfulzeta

Member
Dec 13, 2009
9
0
0
Visit site
Okay everyone.

I had the same problem. If you use Handcent (SP?) SMS that MAY be your problem. The tech (Adam from Oklahoma City) informed me that when you install 3 party apps since at the SMS app, it will block MMS (Even after you've uninstalled it). Try uninstalling all Handcent if you use it and then call Sprint to reset your phone. Mine worked after that and I've had no problems so far. It's been a few days for me now.
 

pingpongitore

Active member
Sep 3, 2009
30
0
0
Visit site
Update your profile menu--settings--about phone--system updates--update profile.
reboot the phone
call sprint, tell them you do have the latest profile for your phone and they need to disable sms/mms, send one to verify it's blocked, then enable sms/mms, then verify again.

This is what was done to fix a hero here after the update, and it has worked fine since.

This worked perfectly for me as I was having the same issue. After updating the profile it worked 10/10 times. Everyone should try this. And yes I too was using Handcent before the battery drain issue was fixed. Give it a try and tell us how it worked out.
 

soulfulzeta

Member
Dec 13, 2009
9
0
0
Visit site
This worked perfectly for me as I was having the same issue. After updating the profile it worked 10/10 times. Everyone should try this. And yes I too was using Handcent before the battery drain issue was fixed. Give it a try and tell us how it worked out.

Tell how how they fixed the battery drain issue. Was that supposed to work after the update? My battery STILL sucks!
 

pingpongitore

Active member
Sep 3, 2009
30
0
0
Visit site
I was talking about the SMS issue where it would drain your battery because it would stop the connection process after the SMS sent. So before they updated the Hero everyone was using things like Handcent SMS, and some people in earlier threads of the post said this was partly to blame why our MMS was now failing.

Basically all I was saying was the fix posted by gbhil worked for me, haha. Should have kept the message short I guess.
 

soulfulzeta

Member
Dec 13, 2009
9
0
0
Visit site
I was talking about the SMS issue where it would drain your battery because it would stop the connection process after the SMS sent. So before they updated the Hero everyone was using things like Handcent SMS, and some people in earlier threads of the post said this was partly to blame why our MMS was now failing.

Basically all I was saying was the fix posted by gbhil worked for me, haha. Should have kept the message short I guess.

Oh okay...I understand now.
 

Forum statistics

Threads
943,948
Messages
6,920,759
Members
3,159,323
Latest member
Gashead