Need to flash Galaxy Tab PRO 10.1 to recover data


New member
Nov 29, 2018
Visit site
This is the one that happens after the purple swirly (sorry for the technical term).

I went through some simple things to try and fix it including reboots.
I also disconnected the battery for some time while pressing the power switch.
I hoped this might clear the issue but it did not.

I tried connecting to my wifes PC where it wasn't recognized (used to work there).
I tried my system as well, I had no SW installed to I tried the latest Kies SW.
Also tried an older Kies version and also Samsung Smartswitch. Later I also tried Odin.
Nothing recognized the tablet as being plugged. Tried several cables to no avail.
If I look in the HW manager on both PCs no tablet shows up.

It seems as if the tablet USB is dead or the SW isn't running far enough to enable it.

Did some research and got into recovery mode, here is what comes up.

Android system recover <3e>

Dead android with "no command" below

In my research I found out that you can update an image from the SD card.
So I found two US (XAR region) roms for Kitkat 4.4.2, I have tried both.
I used "apply update from external storage" in the recovery menu and selected the ROM.
They seem to start loading/extracting on the tablet and then I get the following;

E:footer is wrong
E:signature verification failed

The above message happens twice. The only reason I haven't just resorted to factory settings is my wife did not back up the tablet in the last 6 months and the previous backup has empty directories. While nothing is critical on the table she has save a lot of free quilting/clothing patterns to it.

So whatever I do I am trying to preserve the data, hence my efforts with the ROMS.

I can't change any settings on the tablet, I can't get the USB to work and I keep getting errors with the ROMS. I have seen it suggested that slow downloads can corrupt the zip files I am downloading. I don't want to pay for the download. Is there anywhere to get ROMS free at a decent download speed to rule this out?

Anyone have any ideas for anything else I can try.


B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
I moved this from the Android Graveyard forum to the Tab Pro 10.1 Rooting/ROMs forum, for more specific traffic.


Retired Moderator
Feb 12, 2012
Visit site
1. If you flash a ROM, all data is gone. Your files, your pictures, your texts, etc., etc. All gone. You don't want to flash anything other than a single-file ROM (and you do that through Download, not through Recovery). See [Samsung] How to flash Stock ROM via ODIN - but with a single file version. If you flash the 4 file version, you wipe all your data.

2. The errors you got when you tried "apply update from external storage" is because you weren't using an update file. That has a different footer and a different signature method.

3. Since updates delete themselves after they update the device, try this XDA forum, to see if anyone captured an update for the version of Android your tab is running. Then you can apply it from Recovery. Or see if anyone has a single file ROM for the tab, so you can flash it with Odin.

Members online

Trending Posts

Forum statistics

Latest member