No mobile data unless I toggle airplane mode?

crosspatch

Well-known member
Apr 24, 2012
98
0
0
Visit site
My 6P has started doing something really annoying. If I leave home, I continue to have a strong cellular signal, but I have zero mobile data unless I enable and then disable airplane mode.

When this happens, in the built-in notification drop-down, I'll see a strong mobile signal indicator, but no "LTE," and I truly have no mobile data connection at this point. As soon as I toggle airplane mode, the "LTE" shows up and magically, I have mobile data again.

I always have cellular data enabled, so it's not that I'm turning it off when I'm using Wi-Fi. I don't even have "Restrict background data" enabled, though I do have that setting enabled for many individual apps (which should have nothing to do with this problem).

I'm not rooted, so I don't think any apps could be messing with any relevant settings, and I don't think I have any that would anyway.

Any ideas?
 

PaulQ

Well-known member
Jan 6, 2011
1,984
29
48
Visit site
The thing that caught my attention is that you say you have "Restrict Background Data" enabled for individual apps. I've noticed that Marshmallow handles keeping apps in memory differently that OS's in the past. Maybe one of those apps is hanging around in the background and restricting background data like you have told it to do. Have you tried disabling that restriction on all of the apps you have set it on?

If that's not it, if it were me, I'd go to my carrier's store and swap for a new SIM card. But - maybe others have additional suggestions.
 

crosspatch

Well-known member
Apr 24, 2012
98
0
0
Visit site
There is a system-wide setting to restrict background data, and per-app settings for the same. My understanding is that per-app restrictions on background data should have no effect outside the app in question, and should also not have an effect on the given app if it is in the foreground (i.e. in use). As I mentioned, I do not use the system-wide setting at all (i.e. it is disabled).

Also, it's not just background data that is not working. Even apps in the foreground cannot connect. Therefore, unless I am truly misunderstanding something, this issue can't have anything to do with any background data settings (either per-app or system-wide) at all.

Also, I have rebooted the phone.

If I can't get this sorted out, I'll open a case with Google, and see what they advise. Hopefully it's not the typical "Wipe the entire phone with a new system image" reply.
 

hallux

Q&A Team
Jul 7, 2013
12,322
7
38
Visit site
This happens to me from time to time, also happens when going back to WiFi. There is talk that this is a bug that was introduced with the 6.0.1 update.
 

SupermanJon707

Well-known member
Aug 6, 2014
75
0
0
Visit site
My 6P has started doing something really annoying. If I leave home, I continue to have a strong cellular signal, but I have zero mobile data unless I enable and then disable airplane mode.

When this happens, in the built-in notification drop-down, I'll see a strong mobile signal indicator, but no "LTE," and I truly have no mobile data connection at this point. As soon as I toggle airplane mode, the "LTE" shows up and magically, I have mobile data again.

I always have cellular data enabled, so it's not that I'm turning it off when I'm using Wi-Fi. I don't even have "Restrict background data" enabled, though I do have that setting enabled for many individual apps (which should have nothing to do with this problem).

I'm not rooted, so I don't think any apps could be messing with any relevant settings, and I don't think I have any that would anyway.

Any ideas?

This is a guide on how to switch your Network settings and make sure it is on "GSM/LTE/HSPA+/CMDA auto"

http://forum.xda-developers.com/showthread.php?t=2713752


Also I would try to go and see if replacing the SIM card with a new one fixes this issue

Posted via the Android Central App
 

Trending Posts

Forum statistics

Threads
942,926
Messages
6,916,530
Members
3,158,740
Latest member
taylorhudson5670