No more "options" notification when connecting to PC

anon(3415124)

Well-known member
Aug 23, 2011
49
1
0
Visit site
Hmm, I've found my first snafu since Pie update. When I connect to a PC via USB, the phone just charges. I don't get a notification like I used to that gives me options other than charging, like transferring files. I can't seem to find that option anywhere on the phone, and my computer doesn't even see my PH-1. Am I missing something? I have rebooted both, to no avail. 😕
 

anon(3415124)

Well-known member
Aug 23, 2011
49
1
0
Visit site
Well, I did managed to find the settings. Did a search in settings for "use USB", and got to the page where you have the options. The problem is, they're grayed out, as if the option isn't there. The one or two toggles that seem active fail to do anything. Hopefully this will get corrected, as I normally utilize file transfer. Of course I'll try again at home on a different computer and cables, just to double check.
 

anon(3415124)

Well-known member
Aug 23, 2011
49
1
0
Visit site
Yeah, that's a bummer. Seems like such a basic thing to screw up. Surely it will get corrected. I'm a little surprised I'm not seeing any complaints about this. That's why I was worried I was doing something wrong. I appreciate tiefel checking the Pixel.
 

Roosterman

Well-known member
Apr 3, 2011
367
53
28
Visit site
I have been able to transfer data between my PH-1 and my PC. Trying the above search, I found USB preferences and all choices were available. Use "USB for" was defaulted to No data transfer. I was able to change to File transfer and immediately, my PC say the internal storage.

I am using a USB 3 port with a USB 3 certified data cable. Not sure about a USB 2 port.
 

anon(3415124)

Well-known member
Aug 23, 2011
49
1
0
Visit site
It turns out my cable is a 2.0, so I've got a 3.0 ordered from Amazon. My USB port is 3.0, so I should be good to go. Funny that it worked fine before, but I don't care as long as I can get it working again.
 

anon(3415124)

Well-known member
Aug 23, 2011
49
1
0
Visit site
Okay, final report. USB 3.0 cable fixed the issue. Notification pops up and everything works perfectly as expected. Thanks Roosterman for the heads up! 👍🏻
 

jre72

Well-known member
Oct 23, 2017
65
0
0
Visit site
Every time I plug into the PC, I need to go to the "Use USB for" settings and change it from "no Data Transfer" to "File Transfer"...is there a way to default this to file transfer? If I plug into the PC, I'm moving files, not for charging.
 

anon(3415124)

Well-known member
Aug 23, 2011
49
1
0
Visit site
If there is, I haven't figured it out. Every time I plug it in, I get the notification at the top that it's charging. I have to tap it, then select file transfer.
 

skierpage

New member
Oct 19, 2017
1
0
0
Visit site
Every time I plug into the PC, I need to go to the "Use USB for" settings and change it from "no Data Transfer" to "File Transfer"...is there a way to default this to file transfer? If I plug into the PC, I'm moving files, not for charging.
I enabled developer mode on my Pixel 2, and with this On in System > Developer options there is a Default USB Configuration setting I can set to File Transfer (or USB teghering, MIDI, PTP, or No data transfer).

This is obviously hugely risky if you forget, stick your phone into some random charging point and someone accesses your files.

I'm here because I'm having this problem for the first time. Use USB for is grayed out. Sometimes USB controlled by (Connected device or This device) is enabled. I've tried different ports.
 

droid-drone

New member
Aug 8, 2011
2
0
1
Visit site
I know this is old but I have same problem on my 'mi mix 2'.
Charges but will not show options and I have tried various ports on multiple PCs and three cables
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,529
4,668
113
Visit site
Welcome to Android Central! So you also looked in Developer Options to see if there are any USB options?

It's possible there's a problem with the phone's USB port. Is it still under warranty?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,529
4,668
113
Visit site
Just because it works with a thumb drive doesn't necessarily mean it's fully working as it should. There might be a pin that's damaged. Did you already try cleaning the port by blowing it out with a can of compressed air, and then scrubbing it with a dry toothbrush?
 

Trending Posts

Forum statistics

Threads
942,979
Messages
6,916,717
Members
3,158,760
Latest member
rakhikumari800000