On my SM-T2105 Galaxy Tab Kids - there is a Corrupted USB Connection, can anyone help?

freekey

New member
Nov 1, 2013
4
0
0
Visit site
SM-T2105 Galaxy Tab Kids - Corrupted USB Connection

Monday, 13 October, 2014 04:44:05 PM - SM-T2105 Galaxy Tab Kids - Corrupted USB Connection
---------------------------------------------------------------------------------------
Hi all.

I've spent almost the full 2 days looking for solution of this but to no avail.

My tablet is using 4.1.2 Jelly Bean.

I owned the SM-T2105 Galaxy Tab Kids rooted. Then suddenly I was thinking to move all my apps to SD card. Trying and trying, finally I realized that I need to make separate partitions on the SD card first.

So I one of the solutions I found on the internet told me to make that partition using the PC. Then I am interested to connect my device as mass storage instead of the default MTP connection. So I found an app called SG USB Mass Storage Enabler in the PlayStore.

Without reading any further, I quickly installed it and turn on the mass storage function. But to no avail. My PC can't recognized the tablet anymore since then. Immediately, I quickly uninstalled that app and looking for another app. But still the same problem.

So finally I am stucked with "connected as an installer" whenever I connect the tablet to my PC. And the worst thing that, I cannot change it back to MTP/Camera transfer mode i.e. my tablet would immediately reboot! I was totally intensed since then. After trying and trying, I still cannot find the solution.

Then I thought a firmware upgrade will do. So i install the latest firmware for SM-T2105 - T2105ZHAND2 from here - sammobile. I also rooted it again then.

But still the problem persist. I also end up using the ADB terminal from my PC to issue the
Code:
su
setprop persist.sys.usb.config mtp,adb
reboot
But still the same problem. My device would restart immediately after issuing the command.

I have also found somewhere this code but the issue is I cannot find that /sys/devices/platform/msm_hsusb/gadget/lun0/ path on the tablet:
Code:
Mass Storage Mode
---------------------------------------------------------------------------------------
setprop persist.sys.usb.config mass_storage,adb
echo /dev/block/vold/179:33 > /sys/devices/platform/msm_hsusb/gadget/lun0/file

Return to MTP
---------------------------------------------------------------------------------------
#!/system/bin/sh
echo "" > /sys/devices/platform/msm_hsusb/gadget/lun0/file vold 
setprop persist.sys.usb.config mtp,adb
This /sys/class/android_usb/android0/f_mass_storage but no lun folder inside. Only nluns file is sound
So I am really stressed with this. Can someone here please help me out?

Factory reset would be my last choice.

I was expecting something like system files update or something. Is it possible?

Thank you very much.
 

Trending Posts

Forum statistics

Threads
944,377
Messages
6,922,557
Members
3,159,522
Latest member
nuclei