Orange wifi icon, Google Play not working. How can I fix this?

A

AC Question

Orange wifi icon, Google Play not working

Hello. As I mentioned in the title, I have an orange wifi and mobile connection icon for a few days. Sometimes it turns back white, but the issues are still there. Internet works, but Google Play Store says "No connection" or connects and gets stuck at "Downloading" app (downloading new app or even updating current app). Also, some apps have trouble connecting, some of them (i.e. Google Chrome, Skype, Facebook) work perfectly with no issues.
I tried:
-Rebooting many times. Rebooting to safe mode - same issue.
-Stopping app & deleting cache and data from: Google Play, Google Play Services, Download Manager, Google Services Framework.
-Uninstalling all updates from Google Play Store. After that, it did not update itself.
-Checking hosts file - everything is ok.
-Removing and adding my Google account.
-Restarting the router.
-Booting into recovery and wiping Dalvik, Cache.

These issues have never happened before. I think it's something with google apps/services, but none of the above fixed it.

I have Samsung Galaxy S3 mini running CM 11 (Kitkat 4.4) (It worked for a long time without any issues)
Anyone has any ideas? Have you encountered this problem before? I don't want to do the factory reset, but I think it's the only option.
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Re: Orange wifi icon, Google Play not working

It seems that you've already tried everything on the book short of a factory reset. Definitely it looks like a Google related problem. You could try updating the Play Store through the app settings and tapping on the build number. Play services can be updated if you download the Android Wear app.

I recommend you to register as a member in the forum and create a new thread on the CM subforum. Maybe there's an specific fix for your problem.
 

Forum statistics

Threads
941,523
Messages
6,909,238
Members
3,157,951
Latest member
debbiewoodphillips