Over USB, randomly getting message “Allow <app name> to access <device-name>? [set to OK).

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

Over USB, randomly getting message “Allow <app name> to access <device-name>? [set to OK).

We have an ultrasound scanner that connects to our app on Android devices via USB or a built-in WiFi mini-router.

When connected over USB, one of our customers randomly gets the message “Allow <app name> to access <device-name>? [set to OK). Also, an option to “Always open <app-name> when <device-name> is connected?” (shouldn’t be related, but I tried both on and off). Brand new Samsung Galaxy Android S8 Ultra Tablet.

Unable to duplicate in our offices, even when using the same model ultrasound and same model tablet. As expected, the message only appears on a new Android or after a factory reset. It also runs fine at numerous other customer locations.

Tried (1) Android setting “Allow Notifications” off and on, (2) “Notification Categories” indicates “This app hasn’t sent you any notifications.” (3) WiFi and Bluetooth both off and on, (5) both Android and the app are current, (4) neither Samsung nor Google has had any other suggestions,

Not sure if/how this might factor in. When connecting via the built-in WiFi, any Android or iOS device quickly drops the signal while inside the building, but runs fine in the parking lot or elsewhere. Unfortunately, too many other companies in the building to start shutting off routers, and where this occurred at other locations, changing the WiFi channel in the app, turning off other routers, or resorting to the USB cable always solved it.

Any suggestions much appreciated. Thanks, David
 

Trending Posts

Forum statistics

Threads
945,065
Messages
6,924,086
Members
3,159,653
Latest member
rajurana