Peculiar Problem when wiping data/factory reset

n_thacker

Member
May 31, 2012
8
0
0
Visit site
I am unable to Factory Reset my Motorola Photon. Whenever, I try to reset it wipes data & settings upto May 12, 2012. It would not delete/wipe anything prior to that date.



Kindly help me.

Thx
 

tirith

Resident Linux Fiend
Apr 4, 2011
1,583
54
0
Visit site
Have you tried doing it in the recovery menu instead of through the menu/settings/... Method?

Sent using my MoPho-King photon
 

tirith

Resident Linux Fiend
Apr 4, 2011
1,583
54
0
Visit site
Yes, so you've tried from ui and recovery...?

What data isn't clearing if I may ask?

Sent using my MoPho-King photon
 

tirith

Resident Linux Fiend
Apr 4, 2011
1,583
54
0
Visit site
Sounds like a phone defect... I heard something about a photon "all wipe" package, let me research

Sent using my MoPho-King photon
 

KSmithInNY

#winning
Oct 7, 2009
3,538
1,441
0
Visit site
The way a recovery works it's not possible for it to wipe specific data based off a random selection criteria (like date). It's criteria is partition or directory. You may have something wonky going on but i saw some confusion above so it's worth clarifying:

Tirith was asking if you've tried a reset through the recovery, it can be stock or CWM. You wouldn't need to access fastboot although when at the moto menu clicking volume down to get to android recovery, you would pass by the fastboot option. So were clear you've gone into the moto boot menu, pressed volume down until you see the android recovery options, pressed volume up to select, and wiped from the recovery?

EDIT - Don't worry about the confusion either, i believe moto goes out of their way to make things more difficult ... what am i saying of course they do (hello e fuse and encrypted bootloader and and and).

P.S. I've been 100% convinced and vocal this entire time that Sprint had nothing to do with motos decision around this phones bootloader despite motos claims. I provided example after example of devices sold before and after this that had no such security. I even went as far as to reach out to a friend employed by sprint in R&D who confirmed that Sprint did not at all have that specification for the device. Now Sprint launches what will probably be the biggest flagship phone of 2012, selling more units then the photon could have ever hoped, and look at that .... HTC will unlock the bootloader and turn S off and the phone hasnt even launched publicly. HTC differs from moto in that they dont mind unlocking if you agree to waive warranty, but if the carrier feels differently HTC will not unlock the phone as in the case with the ATT HTC one x. Translation = Sprint ok'd HTC to unlock probably their biggest device of the year.

I dont care that its locked because the community provided an option (which moto broke), what i do mind is sprint didn't ask for it to be locked, moto is blaming sprint, and meanwhile the customers are the ones paying the price. Neither Sprint or moto assisted in the cost of my phone so theres no subsidy, and I'd happily relieve any manufacturer from warranty claims yet nobody is listening to the guy that shelled out $600 for the device.
 
Last edited:
  • Like
Reactions: tirith

n_thacker

Member
May 31, 2012
8
0
0
Visit site
If re-flashing is the only option can someone guide me how to flash a rom.

I am unrooted and on stock rom.

Can anybody guide how to re-flash the stock rom step by step as am a newbie

Thx
 

mrabbott

Member
Jun 7, 2012
5
0
0
Visit site
Just joined the forum because I'm having the exact same problem, except my reset goes back to May 27, 2012. I can delete text messages, apps, data, pics, everything... and after the reset it all comes back as of that date. Also unrooted and on stock ROM.

Spent an hour on the phone with Sprint and the rep (who was thankfully very nice and helpful) was also stumped. Going thru the UI results in a powerup followed by an Android character icon with an attention symbol ("!" in a triangle) over its head that never goes away (at least not while my patience lasted). Going thru the fastboot menu method (power and volume-down; apologies if I've got the terminology wrong), it seems to reset just fine but only back to May 27. I haven't taken it to the Sprint store (fwiw) or run it over with my car yet.

Anyway, you are not alone, n_thacker, and any help would be very welcome and appreciated.

Thanks!
 

mrabbott

Member
Jun 7, 2012
5
0
0
Visit site
Thanks, tirith. Just tried it. As you said, there's a "Reset to factory defaults" option at the bottom, but it wants a 6-digit passcode.
 

n_thacker

Member
May 31, 2012
8
0
0
Visit site
Just joined the forum because I'm having the exact same problem, except my reset goes back to May 27, 2012. I can delete text messages, apps, data, pics, everything... and after the reset it all comes back as of that date. Also unrooted and on stock ROM.

Spent an hour on the phone with Sprint and the rep (who was thankfully very nice and helpful) was also stumped. Going thru the UI results in a powerup followed by an Android character icon with an attention symbol ("!" in a triangle) over its head that never goes away (at least not while my patience lasted). Going thru the fastboot menu method (power and volume-down; apologies if I've got the terminology wrong), it seems to reset just fine but only back to May 27. I haven't taken it to the Sprint store (fwiw) or run it over with my car yet.

Anyway, you are not alone, n_thacker, and any help would be very welcome and appreciated.

Thanks!

I tried to flash it with Stock Rom but the problem remains as it is.

I guess its time to invoke warranty
 

n_thacker

Member
May 31, 2012
8
0
0
Visit site
Just joined the forum because I'm having the exact same problem, except my reset goes back to May 27, 2012. I can delete text messages, apps, data, pics, everything... and after the reset it all comes back as of that date. Also unrooted and on stock ROM.

Spent an hour on the phone with Sprint and the rep (who was thankfully very nice and helpful) was also stumped. Going thru the UI results in a powerup followed by an Android character icon with an attention symbol ("!" in a triangle) over its head that never goes away (at least not while my patience lasted). Going thru the fastboot menu method (power and volume-down; apologies if I've got the terminology wrong), it seems to reset just fine but only back to May 27. I haven't taken it to the Sprint store (fwiw) or run it over with my car yet.

Anyway, you are not alone, n_thacker, and any help would be very welcome and appreciated.

Thanks!

I checked your post on the xda forum. Also I have been in touch with Mark on Motorola forum and he said one more person also has the same problem. He said he is looking forward to recieving handset for either of you so that he can work it out.

I would have sent him my handset but since am based in India it would be difficult. But u can get it rectified by sending it to them.
 

mrabbott

Member
Jun 7, 2012
5
0
0
Visit site
Thanks. I haven't been contacted by anyone and have no other info, except that someone else is having the same problem. I posted another reply on the motorola forum.

I really need to get this resolved and want to do it without the "help" (and questioning) from a tech at the Sprint store, if I can avoid it.
 

mrabbott

Member
Jun 7, 2012
5
0
0
Visit site
@tirith -

Got the code from Sprint. No joy. Same story. The reset starts, then stops with the Android guy and attention symbol ("!") over his head. From there, vol up/down simo and I get to the Android recovery menu. The reset from there rolls me back to the way things were on May 27. Apps, call logs, texts, photos, lock pattern, etc.
 

Forum statistics

Threads
944,558
Messages
6,923,369
Members
3,159,621
Latest member
wadeharper