Pixel 5 keeps reverting to Mobile Calling instead of WIFI calling

Bash_Man

Well-known member
Oct 13, 2013
83
0
6
Visit site
so i am running into this issue.. I have WIFI calling enabled but it wont work for some reason. I've reigstered with Koodo (in Canada) and have enabled it on the phone.

If I put the phone in Airplane mode and turn ON wifi, WIFI Calling comes on and it works. As soon as I turn on Mobile network, it goes away.

I've rebooted the phone, reset the phone app, reset carrier services app, rebooted my wifi, rebooted modem, changed SIM card, changed router, tried other WIFI.

Only thing left for me is to wipe the phone and start again but hesitant to do that to be honest.

any suggestions?

Thanks
 

Scott337

Well-known member
Apr 22, 2017
1,741
101
63
Visit site
I have had several phones work the same way on Verizon in the US. Many complaints about the exact same thing on the Verizon help forum over the past few years. That leads me to believe there is something about the carrier network that interferes with the phone switching to Wi-Fi calling, but I certainly could be wrong.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,206
2,930
113
Visit site
Go to Settings>Network & Internet>Calls & SMS. Tap your carrier under the Wi-fi Calling section, then Calling Preference. Is "Call over Wi-Fi" selected?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,206
2,930
113
Visit site
yep.. the "Use Wi-Fi calling" is enabled.

Right, but do you also see an option for Calling Preference? Mine gives me the option of preferring wi-fi or mobile calling, even with wi-fi calling enabled. I keep mine as mobile calling preferred, because the wi-fi network in my workplace blows.
 

Bash_Man

Well-known member
Oct 13, 2013
83
0
6
Visit site
Right, but do you also see an option for Calling Preference? Mine gives me the option of preferring wi-fi or mobile calling, even with wi-fi calling enabled. I keep mine as mobile calling preferred, because the wi-fi network in my workplace blows.

Yes, but its greyed out. cant click it or change it. Its set to Koodo.
 

Bash_Man

Well-known member
Oct 13, 2013
83
0
6
Visit site
So I spoke to Koodo tech support and they tried a number of things from their side as far as pushing certain settings back out to the phone and a bunch of other things that I had already done my self.

Unfortunetly still no go sadly.

Any other things anyone can recommend?

I am pretty much down to the last option, which is wiping the phone.
 

Bash_Man

Well-known member
Oct 13, 2013
83
0
6
Visit site
Hey everyone,
So I think I figured out the issue... After further troubleshooting with Koodo, I decided to try some troubleshooting my self.

I down graded the mobile speed compatibility as a test to 3G and 2G and all the sudden wifi calling came back ON. Progress made.

Ran a couple of tests and noticed that my mobile connection is faster than my at home wifi and other wifi networks I've connected to lately.

Did some research into this and noticed some other people had a similar issue to this and always came down to similar root cause.

I guess I can put this to rest for now.

Thanks everyone who chimed in with support and input.
 

Trending Posts

Forum statistics

Threads
939,033
Messages
6,892,081
Members
3,156,488
Latest member
BABYLONRUN