Problem with https security certificate on Note 3, server admin says secure, only android problem

Jason Irvine

New member
Nov 10, 2014
3
0
0
Visit site
I have clicked on a link from my mail app to go to a webpage, and I get a red lock icon that states:

YOUR CONNECTION IS NOT PRIVATE, ATTACKERS MIGHT BE TRYING TO STEAL YOUR INFORMATION FROM [DOMAIN]. THIS SERVER COULD NOT PROVE THAT IT IS [DOMAIN]; ITS SECURITY CERTIFICATE IS NOT TRUSTED BY YOUR DEVICES OPERATING SYSTEM. THIS MAY BE CAUSED BY A MISCONFIGURATION OR AN ATTACKER INTERCEPTING YOUR CONNECTION.

PROCEED TO [DOMAIN] (UNSAFE)

When I do proceed, the https is in red and a red line is strike through.

I contacted the webmaster that assured me that it is safe and they are only getting feedback about this from android phones. Any idea what the problem might be? See attached screen shot. Any assistance is most appreciated.


Screenshots_2014-11-21-06-57-02.jpg
 

jpr

Well-known member
Sep 14, 2010
1,700
48
0
Visit site
If this error message started recently it is likely because the website owner has not updated their SSL cert to SHA-2, like they were supposed to do by November 14th. SHA-1 is now considered an insecure connection.
 

jpr

Well-known member
Sep 14, 2010
1,700
48
0
Visit site
Btw, I did just check the website that is included in your screenshot and it is using SHA-1. So they need to fix that ASAP.
 

Roy Moses

New member
Nov 24, 2014
1
0
0
Visit site
Hello!

I hope this is ok to post it here,
but i am getting the same thing for this: try to go to photoalbum .co with https.


which is weird because it's working in my computer in chrome and Firefox..
only not working on my android..

I checked and it has SHA-2
Algorithm Type : sha256WithRSAEncryption

someone know what needs to be done to be able to fix this?

Thanks in advance!
 

Attachments

  • Screenshot_2014-11-24-17-17-29.jpg
    Screenshot_2014-11-24-17-17-29.jpg
    100.7 KB · Views: 5

leebo13

New member
Jun 6, 2020
1
0
0
Visit site
Did you get a fix for this problem? I try to load an app and get "Network Error". Upon going to the site using the default samsung internet and typing in the web address it comes up with the same problem you had which is why the app wont load. I suspect that one of my safety certificates are no longer valid even though the expiry date is still ok. If i use another browser like firefox i have no problems with getting access to the site. Will try and figure out how to update a new CA certificate and import into my phone to see if it fixes the problem...emmm 6 years
 

Forum statistics

Threads
941,329
Messages
6,908,014
Members
3,157,868
Latest member
HeidilB