Problem with my LG Mytouch E739

yung_rottz

New member
Dec 26, 2012
1
0
0
Visit site
ok so yesterday after just getting off a phone call i layed my phone down to play some video games now between games i'd pick up the phone to reply to a few texts here and there until this random moment when i press the power key and my screen doesn't come back up..so my first thought is the phone is off so i hold the power button to turn it on it comes on fine as usual, it shows the LG logo then the start up Android screen but when it gets to the point where it should be showing my menu screen it just keeps showing the Android 4g T-mobile insignia until it just goes black all together..i then decided to charge it, after it maxes out i try it again but still nothing however i did notice in place of the menu there is a small white dot on the top left corner, the screen hasn't been damaged or anything and when i put the phone into the light it looks like there is no punctures inside, the dot is not even there when the phone boots up. does anyone know what's going on? the irritating thing is how i just used the phone like a minute before this happened
 

Bittersweet10496

New member
Aug 7, 2013
1
0
0
Visit site
I have had this phone for several months now, and within the first few months it already started to act up.The top power button doesn't work, completely, I have to rely on chance. In other words sometimes the top button will have the needed power on reaction 30 minutes late or it will do nothing. As of right now the top button isn't working and it is laying on the desk "charging". I read up on in and it said if your top button isn't working:
1.) take out the battery
2.) put phone on charger (without battery)
3.) wait 5 minutes
4.) unplug
5.) and insert battery back in
... they said this should reset it making the phone turn back on. ... I just hope it works, trying it right now.
 

bkxsass

Member
Mar 12, 2013
20
0
0
Visit site
I've had this phone for over a year now and I haven't had any of those problems you both describe. I wonder if you got malfunction in the mechanisms
 

Trending Posts

Forum statistics

Threads
941,619
Messages
6,909,730
Members
3,157,993
Latest member
hennapatel