Problems connecting to home WiFi

nelhop

Well-known member
Oct 9, 2012
119
0
0
Visit site
It used to be that when I turned on my Nexus 5 in the morning it would automatically switch onto my home wifi. It still does that sometimes but not always. Then I have to enter the password to my router and click connect. Sometimes it will then connect. Sometimes I have to repeat this process several times before it connects. It will say "saved" but forgets. The phone and I are both old so I'm tolerant of forgetting. Even more exasperating is that it will automatically connect to an HP printer somewhere in my neighborhood but not my wifi. I have tried to "forget" the printer address but it doesn't go away and I don't know how I can get rid of it. Of course, if I do connect to my wifi and leave the house it disconnects. When I return I have to go through the multiple entering of the password before I can reconnect.

My isp is Comcast and the router is theirs. It was new last January so I assume it is a recent model. Android 6.01 security patch level October 5, 2016.
Any suggestions will be appreciated.
Eva
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,894
3,864
113
Visit site
Log into the router's settings using your computer's browser (look up the router's manual on the web to learn how), and see what kind of security protocol it's set to. Ideally, it should be set to WPA2-PSK/AES.

Also, use an app like Wi-fi Analyzer to see if the wi-fi channel that your router is using is really congested. If it is, try changing the channel.
 

nelhop

Well-known member
Oct 9, 2012
119
0
0
Visit site
Thank you for your help. The security is
Security is set exactly as you suggested. I installed WiFi Analyzer. Of course, I did not understand what it showed. I will try to attach the saved image. It's a bit complicated.
Eva
 

Attachments

  • 2016-12-22-132101.jpg
    2016-12-22-132101.jpg
    134.8 KB · Views: 3

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,894
3,864
113
Visit site
It looks like your router is using the same channel as that other one in blue (which I can't read). Channels 1-3 are not in use, so try changing the wi-fi channel in the router settings to one of those.
 

nelhop

Well-known member
Oct 9, 2012
119
0
0
Visit site
I'm back online again. Many house guests kept me away from my computer to provide a timely response. The two identical wifi peaks are 2805 (my wifi) and Xfinity (Comcast). I changed to channel 3. Both peaks moved to channel 3, again right on top of each other. Comcast is my ISP and when connecting to wifi I always get a choice between those 2. I don't know what security comes with XfinityWifi but there is no little lock on its icon so I always choose my own wifi. The channel selection is automatic unless I choose manual. Today Wifi analyzer has both peaks at 10.

Is there any way to get the phone to forget permanently the HP printer that the phone keeps connecting to? The printer must be shut down today because it is not in the available list today, but I'm sure it will be back.
Thanks for your help.
Eva
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,894
3,864
113
Visit site
The Xifinitywifi peak is coming from your router. With Comcast, every home router will broadcast a public xfinitywireless hotspot that anyone else who has a Comcast account can log into. It is completely separate from your network, and is not supposed to pose any privacy or security risk to you. But here's how you can disable it, if you want: https://customer.xfinity.com/help-and-support/internet/disable-xfinity-wifi-home-hotspot/

Forgetting a network is only if the phone ever connected to it in the first place. You can't prevent the phone from detecting a wi-fi network if it's around.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,894
3,864
113
Visit site
Theoretically, if someone were to connect to your public xfinitywireless hotspot, and then spent the whole day downloading huge files from the web or streaming hi-def videos, it's possible that bandwidth usage might have some impact on your own private wi-fi network's speed -- but in practice, I doubt that ever happens. I'm sure there are other people who have privacy and security concerns about having their own router broadcast a public hotspot. Personally, I don't disable the public hotspot, because the overarching idea from Comcast is to improve nationwide public wi-fi hotspot coverage (at least for its customers). So it can be helpful to you if you're traveling somewhere, need a wi-fi hotspot, and a nearby resident has Comcast and didn't disable their own public hotspot.