S7 edge battery issues

Wrthgdrver710

New member
Dec 24, 2016
1
0
0
Visit site
I just got my s7 edge and the battery is not lasting as long as I feel like it should be. I've heard people that go 12-24 hours on a single charge and that just isn't happening with mine. I left it off the charger for a night and the battery dropped by 15%! As I'm using the phone I see the battery drop before my eyes.

I've wiped the cache, done a factory reset, disabled a bunch of draining options but nothing seems to help. I'm considering returning it for another s7 edge but figured I would see if this is normal for the phone first.

First time posting so if I'm missing anything please let me know.

Here's a screenshot of gsam
http://imgur.com/w3yeyV7
 
Last edited:

ThrottleJohnny

Trusted Member
Apr 1, 2014
2,761
0
0
Visit site
If you just got the phone, let it charge a few cycles. My battery got stronger after a few full charges. Also, check your signal strength
 

parth00790

Member
Dec 24, 2016
21
0
0
Visit site
may be you need to calibrate battery .
for this just drain out your battery completely and change it while turned off . do this two three times and then done
 

parth00790

Member
Dec 24, 2016
21
0
0
Visit site
bro for recalibration of battery it must be done once atleast .
calibration issues are common in Android gadgets dont worry it will not create any problem
 

parth00790

Member
Dec 24, 2016
21
0
0
Visit site
if there are irregular patterns in battery drop or charge then possibilities are there of bettery stats issues . so calibration is just repair ing this
 

jejb

Well-known member
Aug 3, 2012
380
0
0
Visit site
I just got my s7 edge and the battery is not lasting as long as I feel like it should be. I've heard people that go 12-24 hours on a single charge and that just isn't happening with mine. I left it off the charger for a night and the battery dropped by 15%! As I'm using the phone I see the battery drop before my eyes.

I've wiped the cache, done a factory reset, disabled a bunch of draining options but nothing seems to help. I'm considering returning it for another s7 edge but figured I would see if this is normal for the phone first.

First time posting so if I'm missing anything please let me know.
Not normal for mine. I left mine unplugged the 2nd night I had it, after charging to 100%. It lost 3% in 7 hours, and that's been consistently the case every time I've tested it that way. I run BT and Wifi all the time, location off, wifi searching off, I don't use any social media apps on my phone like FB, etc. Stock phone, no disabler, no greenify, no doze apps, run TW. VERY impressed with the battery life on mine.

One thing to try is dumping your cache. Settings->Storage. Touch cache and confirm delete. You may want to dump the cache in the recovery mode, too (hold down the vol up, home and power buttons at the same time from a powered off phone to get to recovery).
 

Forum statistics

Threads
941,386
Messages
6,908,468
Members
3,157,891
Latest member
iyekdroidcentral2