Samsung Note 5 and Google App/Android Wear problem

Rikutan

New member
Feb 18, 2016
1
0
0
Visit site
I just got a note 5. I installed Android wear and opened the app to pair it, as usual. When I did, it gave me the following: "Update your Google app on the Play Store, Then open Android Wear again." I choose to upgrade, and the Play store informs me that "my device isn't compatible with this version."

Has anyone else figured out why this is?
 

SpookDroid

Ambassador
Jul 14, 2011
19,279
528
113
Visit site
Re: Samsung Note 5 and Google App

That's odd... I have a Note 5 and it didn't ask me to upgrade anything. My Google app is up to date (at least to the one showing in the Play Store for mine) and my Moto360 is working without issues, so I'm guessing so is the Android Wear app... Maybe the link the Android Wear app is taking you to is a different one? Have you tried manually looking for a Google App update? Or maybe tried rebooting your phone and seeing if the update shows up?

If it helps, these are my app versions:
Google 5.8.57.19.arm64
Wear 1.4.0.2552934.gms
 

SpookDroid

Ambassador
Jul 14, 2011
19,279
528
113
Visit site
Re: Samsung Note 5 and Google App

I...wouldn't do that if I were you. Unless you know this comes from a REPUTABLE source AND from the same model you're trying to use it for (yes, versions may change for different models), it might end up doing more harm than good.
 

kcodya

Well-known member
May 22, 2011
161
7
0
Visit site
Re: Samsung Note 5 and Google App

It's a reputable site, I download from it all the time. It's run by Android Police. This is the correct version for the Note 5.
 

SpookDroid

Ambassador
Jul 14, 2011
19,279
528
113
Visit site
Re: Samsung Note 5 and Google App

Just have to do the usual 'Proceed with caution and at your own peril' kinda speech :) haha
 

Forum statistics

Threads
942,859
Messages
6,916,265
Members
3,158,702
Latest member
MapleSyrup