Slow data speeds on AT&T

hkdflip2

Member
Sep 24, 2012
6
0
0
Visit site
So I just got the nexus 4 and have been doing some speed tests using att network. I used speed test.net and my data speeds are pathetic at best. I know I wont be getting LTE but hspa+ should be getting more than 1mbps download. I'm achieving only 9 kbps download and 1557kbps upload. Is there something I need to tweak to achieve faster speeds or could I have a defective phone? Any tips would be great.

thanks,
Mike
 

donm527#IM

Well-known member
Nov 15, 2012
626
0
0
Visit site
http://forums.androidcentral.com/google-nexus-4/226814-anyone-activated-nexus-4-att.html

So I just got the nexus 4 and have been doing some speed tests using att network. I used speed test.net and my data speeds are pathetic at best. I know I wont be getting LTE but hspa+ should be getting more than 1mbps download. I'm achieving only 9 kbps download and 1557kbps upload. Is there something I need to tweak to achieve faster speeds or could I have a defective phone? Any tips would be great.

thanks,
Mike
 

hkdflip2

Member
Sep 24, 2012
6
0
0
Visit site
So I'm trying to edit the APN settings and I followed the links you guys sent me. However I select save but when I exit out I don't have anything there to select with the new values. Any suggestions ?

Sent from my Nexus 4 using Android Central Forums
 

hkdflip2

Member
Sep 24, 2012
6
0
0
Visit site
Scratch that got it to work and now I'm getting around 3mbps and 1 upload. Is there specific settings for chicagoland area ?

Sent from my Nexus 4 using Android Central Forums
 

jedah

Well-known member
Sep 12, 2011
217
19
0
Visit site
9Mbps sounds pretty good for ATT. In LA, I typically get 5-10Mbps on ATT's LTE w/ my GS2 Skyrocket (though it's faster here in San Francisco). Maybe it's just the particular area you're in?
 

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
So I just got the nexus 4 and have been doing some speed tests using att network. I used speed test.net and my data speeds are pathetic at best. I know I wont be getting LTE but hspa+ should be getting more than 1mbps download. I'm achieving only 9 kbps download and 1557kbps upload. Is there something I need to tweak to achieve faster speeds or could I have a defective phone? Any tips would be great.

thanks,
Mike

9 MBPS down and 1.5 up? What are you complaining about? Those are pretty much on par what you're supposed to get with AT&T HSPA+ and those are great speeds. I average around 5 mbps down and everything that involves data works pretty fast.
 
Last edited:

Downtown Taco

Well-known member
Jan 19, 2012
643
33
0
Visit site
9 MBPS down and 1.5 up? What are you complaining about? Those are pretty much on par what you're supposed to get with AT&T HSPA+ and those are great speeds. I average around 5 mbps down and everything that involves data works pretty fast.

Yea, I should get off of Sprint now.

What do you all believe is faster for the Nexus 4, AT&T or T-Mobile?

Sent from my Galaxy Nexus using Tapatalk 2
 

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
Yea, I should get off of Sprint now.

What do you all believe is faster for the Nexus 4, AT&T or T-Mobile?

Sent from my Galaxy Nexus using Tapatalk 2

Yeah you need to get off Sprint, they are a terrible provider, their 3G speeds are poor and they are CDMA.

TMobile HSPA+ speeds are faster than AT&T but TMobile's coverage is not good outside major metropolitan areas. AT&T's still has good speeds but aren't as good as TMobile but their coverage footprint blows TMobile's away hands down. IMO if you have over 3 MBPS you are good to go. I live in upstate NY away from a major city and I have gotten as much as 9 MBPS down with AT&T. Tmobile's coverage up here is sporadic to nonexistent.
 

jimrebello

Well-known member
Aug 14, 2012
193
0
0
Visit site
9 MBPS down and 1.5 up? What are you complaining about? Those are pretty much on par what you're supposed to get with AT&T HSPA+ and those are great speeds. I average around 5 mbps down and everything that involves data works pretty fast.

Hes getting 9kbps not mbps.

Sent from my SGH-I896 using Android Central Forums
 

nickacs

Well-known member
Mar 28, 2010
585
1
0
Visit site
TMobile HSPA+ speeds are faster than AT&T but TMobile's coverage is not good outside major metropolitan areas. AT&T's still has good speeds but aren't as good as TMobile but their coverage footprint blows TMobile's away hands down. IMO if you have over 3 MBPS you are good to go. I live in upstate NY away from a major city and I have gotten as much as 9 MBPS down with AT&T. Tmobile's coverage up here is sporadic to nonexistent.

Agree 100%. I'm on my 2nd month now of TMobile prepaid $30 service and while I'm "satisfied" with the service so far, I'm going to try ST AT&T for next month. I'm in the Atlanta area and while my TMobile speeds have been awesome at my house/around town (~12-18MBPS), I get almost zero building penetration at work during the week. I'll get an email notification like twice a day, where I should be getting them like 20 a day, at least. And this is a huge dealbreaker for me. Can't use any data connection hardly.
I know ST AT&T will probably yield slower data speeds, but being able to use my phone for where I am 80% of a 7 day week is more important to me. I love the $30 price and 5GB unlimited data before throttle, where ST has all the "2GB" throttle BS limit, I'll have to try it. Some people say they have no problems with ST, while others do. I'll have to make my own decision.
 

XxTacticS

Member
Dec 28, 2012
14
0
0
Visit site
how have you guys been testing your speeds? The speed test app always finds servers in the midwest and I live in CA so I'm not sure what my actual speeds are.
 

Jnorton2724

Well-known member
Nov 6, 2012
795
0
0
Visit site
Make sure your using the correct APN settings and it should find local servers to test.

Sent from my Nexus 4 using Android Central Forums
 

XxTacticS

Member
Dec 28, 2012
14
0
0
Visit site
Make sure your using the correct APN settings and it should find local servers to test.

Sent from my Nexus 4 using Android Central Forums

I was using the wap.cigular APN and I just switched it to one linked above. This time the Speedtest app found Portland, OR to be the closest server and I ended up getting 1.94 mb/s download, 0.96 mb/s upload and 94 ms ping.

Should my speeds be better? Is there anything else I can do to improve it.? I'm not sure if my AT&T plan has anything to do with this but I know I have the unlimited data package.
 

jweimn

Well-known member
Sep 2, 2011
464
3
18
Visit site
I getbslow speeds too in my home area but if I go about to a larger city with 4g lte available my speeds improve greatly. Id say blame the network not the phone.

Sent from my SCH-I605 using Tapatalk 2
 

Forum statistics

Threads
942,860
Messages
6,916,269
Members
3,158,702
Latest member
MapleSyrup