Some Apps stops when showing details

Finn Jensen

New member
Dec 25, 2012
4
0
0
Visit site
I have had my Nexus 7 for 3-4 weeks now and everything worked perfect until today.

A number of Apps stops working (crashes) when selecting a detail in the app, or even when starting it.

Some examples:

Using gmail: when I select a mail to view, the app stop. I can see the list in the inbox, but when I select a mail, the screen make space to present the mail, and the the app disappear from the screen.
Using Currents: I get the library screen and when I select a news source, It shows some contents very shortly and the it returns to the library screen.
The game "Spades free" from "AI Factory Limited": when I start the game the introduction screen is shown and a a card is flying in - then the app crashes.

Other Apps runs just fine - gmaps, G+, youtube.

I have tried to reset the Tablet to factory settings without any change.
I am running the Android 4.2.1 Kernel version 3.1.10-g22b4fcd

Is this a known problem? Can it be a hardware problem? Network, sound, GPS - all works fine.

Regards
Finn
 

Finn Jensen

New member
Dec 25, 2012
4
0
0
Visit site
After further investigations, it seems like it is apps that communicate through the wifi that fails.

I have tried to switch off the wifi and then the game function as it should. The game seems to connect to a server when the wifi is on.
It also appears that the programs that fails are doing some kind of load before they fail, so there is a connection there.

ON the other hand the chrome browser works fine, so it is an app that communicate, but not through the browser.

And it is a new problem. It actually happened after the machine was frozen using google maps, and restarted after several minutes.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,796
5,014
113
Visit site
Try uninstalling Spades Free and see if the problem persists. I'm always a tiny bit suspicious of free games that require internet access.
 

Finn Jensen

New member
Dec 25, 2012
4
0
0
Visit site
Having investigated this problem further it seems to be an issue arrising from a stack overflow.

I have the following messages from the log, and it is a sequence like this that comes each time an application fails and crashes.

12-26 13:14:22.107 I/dalvikvm( 6803): Turning on JNI app bug workarounds for target SDK version 6...
12-26 13:14:22.237 D/dalvikvm( 6803): GC_CONCURRENT freed 191K, 5% free 7674K/8020K, paused 4ms+4ms, total 23ms
12-26 13:14:22.237 D/dalvikvm( 6803): WAIT_FOR_CONCURRENT_GC blocked 11ms
12-26 13:14:22.287 I/Ads ( 6803): To get test ads on this device, call adRequest.addTestDevice("E66CC6EE0100D2923647718D8E5B7A64");
12-26 13:14:22.327 I/Ads ( 6803): adRequestUrlHtml: <html><head><script src="http://www.gstatic.com/afma/sdk-core-v40.js"></script><script>AFMA_buildAdURL({"preqs":0,"u_sd":1.3312501,"slotname":"a14d786042cf986","u_h":905,"u_w":600,"msid":"ukzzang.android.app.logviewer","js":"afma-sdk-a-v4.1.1","isu":"E66CC6EE0100D2923647718D8E5B7A64","format":"320x50_mb","net":"wi","app_name":"1101.android.ukzzang.android.app.logviewer","u_audio":3,"hl":"en"});</script></head><body></body></html>
12-26 13:14:22.337 D/ukzzang_common( 6803): logcat process create success. : command(logcat -v time *:V System.out:S)
12-26 13:14:22.337 D/ukzzang_common( 6803): logcat reading start ...
12-26 13:14:22.437 D/dalvikvm( 6803): GC_CONCURRENT freed 298K, 6% free 7805K/8252K, paused 9ms+3ms, total 55ms
12-26 13:14:22.837 I/Ads ( 6803): Received ad url: <"url": "http://googleads.g.doubleclick.net:80/mads/gma?preqs=0&u_sd=1.3312501&u_h=905&u_w=600&msid=ukzzang.android.app.logviewer&js=afma-sdk-a-v4.1.1&isu=E66CC6EE0100D2923647718D8E5B7A64&format=320x50_mb&net=wi&app_name=1101.android.ukzzang.android.app.logviewer&u_audio=3&hl=en&u_so=p&output=html&region=mobile_app&u_tz=-60&client_sdk=1&ex=1&slotname=a14d786042cf986&caps=th_sdkAdmobApiForAds_di&jsv=41", "afmaNotifyDt": "null">
12-26 13:14:22.877 D/dalvikvm( 6803): GC_CONCURRENT freed 58K, 3% free 8139K/8348K, paused 3ms+4ms, total 31ms
12-26 13:14:22.877 D/webviewglue( 6803): nativeDestroy view: 0x58e4fcc8
12-26 13:14:23.177 F/libc ( 6803): Fatal signal 11 (SIGSEGV) at 0x7464697f (code=1), thread 6818 (WebViewCoreThre)

The last two lines do always appear in the log when the app fail.
The error always happens when the wifi is connected, not when it is unconnected.
It is in several applications - GMail (native), Currents, and some games.

Some questions:
a) why is this happening?
b) the error started in a period where I did not install any apps?
c) can it be a problem outside the Nexus 7, e.g. some data returned which result in an unexpected error?

A reinstall of factory setup does not seem to solve the issue.
I am reluctant to manual install the operating system (by rooting) as it impact warrenty.
Hope for your help.