Status 7 not solved!

Pkeshin

New member
Aug 22, 2013
1
0
0
Visit site
I have a Sony Xperia LT22i (nypon). I had the stock version of jb by sony i.e., 6.2.A.1.100.
I have been trying to flash FXP233-cm-10 for xpeira p on my phone but the process has not been successfull.
the cwm recovery kernel alongwith the ROM is 6.0.2.8
I also have a cwm recovery kernel version 6.0.3.2
I successfully pushed the files into the sdcard but the installation from zip failed due to status 7.

The error shown is:
assert failed: getprop("ro.product.device") == "LT22i" || getprop("ro.build.product") == "LT22i" || getprop("ro.build.product") == "LT22i" || getprop("ro.product.device") == "LT22a" || getprop("ro.build.product") == "LT22a" || getprop("ro.product.device") == "nypon" || getprop("ro.build.product") == "nypon"
E:Error in /sdcard/update.zip
(Status 7)
Installtion aborted

I tried editing the updater-script & then running the installation but then the log shows:

Finding update package...
Opening update package...
Installing update...
Installation aborted.

My current status of phone is:
Recovery= CWM v6.0.2.8
Wiped dalvik cache
Wiped system("I did that accidentally")
Factory reset also

I also have the zip file FXP228-cm-10 for xperia p
both of them use the same cwm version
when i tried installing it, it showed the same error as above

Please help

the kernel version that i've is 3.0.8-FXP-g9426a6e
 

Scott Kenyon

Well-known member
Apr 2, 2011
2,060
1
0
Visit site
The usual cause of a status 7 is a bad/wrong recovery or your rom file is bad. If you downloaded Cyanogen from their website, I'd say it's the recovery. Perhaps try TWRP?