Text message notifications are delayed when the screen is locked

randomaltname

New member
May 27, 2012
2
0
0
Visit site
Switched from the original EVO 4G to this, used Google Voice on both phones to manage texts and voicemails.

I've noticed when my screen is locked and I'm on WiFi, I won't be immediately notified that a text has arrived. The second I hit the power button to wake up my phone, all the texts are delivered and the notification sound occurs.

Obviously, this is bad. Any ideas on how to fix this?

EDIT: I also notice my Gmail notifications are slightly delayed too. On my old EVO, I'd get notified the second an email was sent.

EDIT 2: Further investigation has revealed this is an issue only when WiFi is on. If I'm using 3G, it works as intended.
 
Last edited:

roflwaffleton

Well-known member
May 19, 2012
262
5
0
Visit site
Re: Text message notifications are delayed when the screen is loc

There is a setting under Wi-Fi>Advanced Wi-Fi to "Keep Wi-Fi on during sleep" which may not have been enabled.
 

jlo8720

Well-known member
Aug 15, 2011
296
33
0
Visit site
Re: Text message notifications are delayed when the screen is loc

texts dont come over wifi which is weird .


I have mighty text and my texts pop up on the computer a long time before the notification sound on my phone goes off. not sure whats causing this.
 

cgardnervt

Well-known member
Jun 24, 2011
3,556
118
0
Visit site
Re: Text message notifications are delayed when the screen is loc

My One X sometimes has this issue. Not to often. Could be a bug. Stock messaging app?
 

meenas9

Active member
Aug 1, 2012
30
1
0
Visit site
i have the same prob on my att S3. Msg notifications come in about 15 to 16 mins after they were actually sent (according to the time stamp!).