Unlocked M8 Help

Hvacmanjc

Well-known member
May 22, 2012
186
6
0
Visit site
Hey everyone..My wife and I recently switched from Sprint to AT&T and I purchased an unlocked M8 from Amazon. Brand new, never opened and really a bad a$$ phone! I am having a really weird issue with it. Took the phone to AT&T, they placed a SIM card in it and I was out the door. Went home and connected to Wi-Fi so I could download my apps from Google Play. The next morning, I left for work and noticed I had no data at all. Phone and text worked, but no data. Went into settings and it said "disconnected" under data. After about 3 hours or so, I looked and had data back. I returned the phone and was sent a second Brand New phone. This one is doing the exact same thing. When I disconnect from WiFi, it takes roughly 3-5 hours for data to come back. I went to AT&T and received a new SIM card and that did nothing. I have googled and seen where this has happened to others but I can't seem to find a fix. Any info/help would be greatly appreciated. This is getting so frustrating. :mad:
 

Hvacmanjc

Well-known member
May 22, 2012
186
6
0
Visit site
After the data comes back, I have great LTE. Even when the "H" is on the top of the screen(HSPA I guess) it's still really snappy so everything works great after the data comes back.
 

mcaspe1

Well-known member
Apr 23, 2010
268
17
18
Visit site
I had an issue a few weeks ago. Same thing. All of a sudden I lost mobile data. I have an att unlocked phone with a gophone Sim. I think somehow somewhere gophone may have changed their APN. I looked up a new APN, entered it and all is working fine now.

Posted via the Android Central App
 

Hvacmanjc

Well-known member
May 22, 2012
186
6
0
Visit site
I have the same thing...Unlocked with a Gophone SIM. Still havnt really figured it out. AT&T wasn't a whole lot of help because it's not their phone. They say the APN settings were all correct. Can someone with an HTC One on AT&T post a screenshot of the APN settings. Different websites show a lot of different APN configurations.
 

mcaspe1

Well-known member
Apr 23, 2010
268
17
18
Visit site
Try this. Works for me.

Posted via the Android Central App
 

Attachments

  • 4331.jpg
    4331.jpg
    30.5 KB · Views: 12
  • 4332.jpg
    4332.jpg
    35.1 KB · Views: 11
  • 4333.jpg
    4333.jpg
    35.7 KB · Views: 12

Hvacmanjc

Well-known member
May 22, 2012
186
6
0
Visit site
As you can see, data disconnected and no data icon in the status bar. Entered the APN you posted and made no difference. Sorry for the sun glared pic.

Posted via the Android Central App
 

Attachments

  • 20141124_125614.jpg
    20141124_125614.jpg
    43.4 KB · Views: 11

mcaspe1

Well-known member
Apr 23, 2010
268
17
18
Visit site
As you can see, data disconnected and no data icon in the status bar. Entered the APN you posted and made no difference. Sorry for the sun glared pic.

Posted via the Android Central App

Sorry. I have no idea. Are you sure the mobile data setting isn't turned off? That all I can think of unless you aren't unlocked.

Posted via the Android Central App
 

Forum statistics

Threads
943,803
Messages
6,920,146
Members
3,159,242
Latest member
MelmanVT