Why do my app downloads from Play Store get stuck?


New member
Jul 26, 2018
Visit site
I have a problem with downloading and updating apps through the Google Play Store on my Asus tablet ASUS ZenPad 3S 10 (Z500KL), running Android 7.0

This may be a bit of a longer description because I’m trying to include details that may point to the root of the problem, but they may also be irrelevant. I will start off with the most important facts and add details later.

I started having problems with the Google Play Store, in the sense that downloading or updating apps stopped working. The update or download starts and shows ‘downloading’ but it never shows any progress. It also seems that other downloading functions, specific only to Google apps, are affected, i.e. making Google Docs available offline. If something like that is pending, Play Store downloads get stuck on the message ‘download pending’. It seem to me, this all points to Google Play Services.

Before you start pointing me to the standard solutions like cleaning the cache of Google Play Services etc. (details further below), please let me say that I already tried a lot of these troubleshooters. They work - but my problem is that the issue keeps coming back, i.e. I manage to update apps for a few hours and then, after a while, the downloads get stuck again. So, I’m looking for a solution that prevents the problem from coming back.

In that regard, I encountered a subsequent problem, even though I don’t know if it is related: I am unable to uninstall updates to Google Play Services. I know that I need to deactivate Google Pay as device administrator but even after I did that I’m still getting the message that I first must deactivate the device administrator. I also noticed that apps are listed twice as device administrators (in my case Find My Device, Google Pay and Prey). If I check on running services in Developer Options I also see two entries for Google Play Services.

That’s the rough summary - now more details:

What I tried:

First, I unsuccessfully played around with deleting cache and data for Google Play Store, Google Play Services, Google Play Services Framework and Download Manager. First that didn’t work but then I found a troubleshooter that, when I followed the exact same order of action, worked
The troubleshooter that worked recommends to do first all of the above and then Reset app preferences and remove your Google account. I think removing app preferences is somehow important
This solved the problem but after a while it came back. For a while I suspected the pre-installed Avast Mobile Manager with functions like battery saver or especially Autostart-Manager to interfere but I’m not sure
Since removing app preferences requires time-consuming actions afterwards and makes me lose all downloads to the SD card for apps that you can set to download to SD, like Netflix or Spotify, I played around a bit to see if there are quicker solutions.
Here are a few solutions that sometimes randomly work and sometimes don’t: Switch Wifi off, restart, switch Wifi back on. Wifi off, disable Download Manager and Google Play Store, Wifi on, re-enable Download Manager and Play Store. I got plenty more examples but they all have in common that they don’t always work and the problem always comes back

Other observations:

It can even stop in the middle of an update queue, i.e. 2 apps get updated and the third gets stuck on ‘downloading’
I tried to remove and remount the SD card. There seems no problems with it
As already mentioned above, I unsuccessfully tried to uninstall updates of Google Play Services due to problems with device administrators. I also tried to install Google Play Services from third party sources but the installer says to all of them that the install package appears to be corrupt
To find the problem on a ‘cleaner slate’ I also added a second user to the tablet. There, things are even worse: Play services stop working during setup. During setup, the tablet connects to WiFi but keeps returning to the WiFi setup screen. I’m unable to log into my Google account. I couldn't mount the SD card. The only way to install apps is through a browser download of the apk but once installed they keep stopping, even if they are non-Google apps that don’t rely on Play Services.

Because of the above experiences with adding a new user, I’m also somewhat reluctant to attempt a factory reset, which I’m sure will be suggested. What if the tablet then looks like it does when I add a new user?


New member
Aug 17, 2018
Visit site
I am having a similar issue on two brand new Galaxy S9+ running - They won't download or update via google play while connected to Wi-Fi networks. Both new app downloads and app updates are forever stuck in a "Downloading" state and they never download. If I turn wi-fi off, they download just fine over cellular data. I have tried the following:

1. Delete Cache / Data - Google Play, Google Play Services
2. Log out / Log in google account
3. Android Safe Mode
4. Reset Network Connections
5. Tried disabling IPV6 on router
6. Tried Opening ports 5228-5230 on router
7. Completely Reset Router
8. Tried Different Router / tried the additional settings and completely reset router
9. Called AT&T, Samsung, Router company, and my ISP


This is the dumbest thing ever, especially since it's a brand new phone.

Forum statistics

Latest member