• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

Why does settings crash when I try to access my APN settings?


AC Question

I bought a brand new Blu Studio 5.0 HD LTE last week and since Saturday I've been trying to get mobile data on my phone. I know i need to change the APN settings for that to happen but when i click on "Access Point Names" in the settings menu i get the error message "unfortunately settings has stopped". I rebooted in safe mode as suggested on other posts and the problem persisted, I did a factory reset and then rebooted in safe mode, still no dice. I tried resetting all app preferences and clearing random app caches - grasping at straws pretty much. Any help would be greatly appreciated!

Notes: phone came with android kit kat 4.4.2 installed

B. Diddy

Senior Ambassador
Mar 9, 2012
Welcome to Android Central! You've done all of the right things. It sounds like the phone is just defective. Since it's new, bring it back to the store and get an exchange or refund. Show them the problem, if they're reluctant to accept it back.