Why isn't my Play Store working after the root?

A

AC Question

Play store not working after root

I rooted my Note 3 with Kinguser and after the root my play Store app is not functioning. It is still on my phone but when I click on it, it just opens and closes instantly. I tried clearing the cache, force stop, turning the app off and on again, downloading the newest Play Store app from my browser, I also cleared the cache from the download manager and closed and opened it again, I even did a factory reset and nothing has worked.

Anyone have any ideas of what the problem could be and how to fix it? Is there another file that could have been deleted or corrupted that would prevent Play Store from functioning correctly? There is one clue I notice but I don't know what to make of it. When I clicked on the the other "play apps" play books, play games, play music and play newsstand, I get an error message with play games that says Google play services is missing on my phone. This is strange because I see google play still listed on my homepage and on my app manager under "all". No clue why play games doesn't see it but apparently the other play apps do? Not sure this clue is helpful but its something I noticed so I though it best to give as much info as I could. Thanks in advance for the assistance in solving this mystery
 

Forum statistics

Threads
943,941
Messages
6,920,714
Members
3,159,316
Latest member
rjogi3777