WiFi disconnects in sleep

crxssi

Linux: The power beneath
May 31, 2010
2,668
155
0
Visit site
OK, there have been other threads about strange WiFi behavior, especially disconnections. But they are all about when USING the phone. I have not experienced that.

BUT.... I have been experiencing pretty consistent disconnecting after the phone has been sleeping (unused) for a while. I pick up the phone after an hour and it is no longer connected to WiFi, it talks to 3G for a moment, then suddenly realizes there is WiFi and reconnects. I didn't want to post anything until I was sure this was not a fluke. This is not good, because it means any background data will be going through 3G instead of WiFi, which is much more battery usage. It also is much slower. It also means you cannot connect to your sleeping device across the network. And, it is also very annoying to have to wait for it to connect again when you want to do something quickly.

* It is not a fluke- it has been doing it day after day.
* It does it at home and at work.
* It does it even if the phone has not moved more than a few feet from the access point.
* I use Linksys WRT54G routers running Tomato Toastman at home and work. WEP at home, no WiFi security at work.
* The default setting of "Keep W-iFi on during sleep" is active (set to "always") and I have never changed it.
* All WiFi settings are set to stock/defaults.
* There doesn't seem to be a magic amount of time in sleep before it does this.
* Never had the problem on my Evo 3D, Evo OG, or Xoom, and using them in the exact same way with same access points.

UPDATE: Many users have confirmed this happens. Has been reported to HTC and they reluctantly confirm it does this but offer no solid explanation as to why.

UPDATE 2: As can be seen in postings below, there WAS an app that fixes the problem called HTC Smart Sync Disabler.

UPDATE 3 (Jan 2012): I don't seem to have this problem in Jellybean, but I also have Power Saver and Connections Optimizer off. FYI- the "HTC Smart Sync Disabler" app has disappeared completely off Google Play
 
Last edited:

crxssi

Linux: The power beneath
May 31, 2010
2,668
155
0
Visit site
I have noticed this also. It reconnects really quickly though.

Good, I have confirmation that I am not crazy. Looks to me like another bug or a flawed design. It might also explain some of the extraordinary "idle" battery times? It is almost like the phone is INTENTIONALLY (by design) overriding the "stay connected" setting under certain conditions.

But the fast recovery time is no consolation if you were doing a long/slow download, or if you are not near the phone and want to ssh into it, or if you are running some data logging program (note I have not confirmed it will lose connection in any of those conditions except the first).
 

hypercubexl

Active member
May 17, 2012
35
8
0
Visit site
Have not played with that. Not using anything right now where I would need to access the phone during sleep, but have noticed it flipping the wifi back on when it wakes. On my network here it reconnects so fast I've never been able to even press anything before the wifi icon was back on though. Hasn't hurt battery life at all that I've seen.

Just turned the setting to "always" and it seems to be staying on, but it is also plugged in and charging. I will test it later to see if it stays that way on battery.
 

webhaus

Member
May 12, 2012
21
1
0
Visit site
I've noticed the same problem. When i first wake it up, the X is over the wifi symbol.. takes a second or two for it to regain connection. I don't have 3G at my house because I'm in a dead zone and have an Airage. I've noticed that any apps i had open that required data connections will pop up a message saying they are unable to connect. I see this as a problem since i do sync, stream, etc from the phone to my computer and this connection fails after the phone is asleep for more than a few minutes.
 
  • Like
Reactions: crxssi

k000

Well-known member
May 12, 2012
197
4
0
Visit site
Won't this be an issue if I have auto update on some magazines/podcasts? I had heard of this behavior from someone on iPhone 4 s as their data plan kept blowing up... But wow good find. Hope HTC fixes this soon.

Sent from my EVO using Tapatalk 2
 

crxssi

Linux: The power beneath
May 31, 2010
2,668
155
0
Visit site
Won't this be an issue if I have auto update on some magazines/podcasts? I had heard of this behavior from someone on iPhone 4 s as their data plan kept blowing up...

Theoretically, yes. But we don't know for sure. It COULD be that if an app requests data, it might re-wake the WiFi search. But that has not been tested. If it doesn't work that way, then the data will be sucked through the 3G/4G network instead, since that connection can't go down (or you would not have a "phone") and I guess you are just screwed if you have no Sprint signal but do have WiFi. Oh, and screw the battery if your Sprint signal is really weak but it is being forced to talk over that power-expensive channel instead of the WiFi router a few feet away.

As for the iPhone comparitons- Doesn't impact us as much on Sprint, since we have "unlimited data", but it is still annoying, and it totally prevents any spontaneous remote connections TO the phone.

But wow good find. Hope HTC fixes this soon.

That is the question of the day... is this "broken"? Is this a "bug"? Or did HTC intentionally cripple "background WiFi" for some reason, like to artificially boost battery life?
 
  • Like
Reactions: k000

crxssi

Linux: The power beneath
May 31, 2010
2,668
155
0
Visit site
Not only does it disconnect with long idle times, it seems to even "pause" with short times. I neglected to report this in the first posting, but tonight is the third time it has happened:

I turn on the phone and use it a bit, I get a notification of 6 or 7 program updates, at least one of which is a large program. I am done with what I am doing, so I launch the Play Store link from the notification. I approve the mass update. I see it download and install a few apps, without touching the screen. It goes to sleep. I walk away. Come back much later and it is pretending to download one of the apps and had zero progress and no error. I stop that one and click on "update" again, approve it and it is immediately downloaded and installed.

This seems to indicate that the phone immediately is pausing downloads when the phone goes to sleep. Which is even worse than a total disconnect from WiFi association after a long time of idle.
 

Anthonicia

Well-known member
Apr 16, 2011
188
19
0
Visit site
Ummm, u can turn off your mobile network. There's also apps like juice defender that will moderate your connections while in sleep mode.

I know it should be fixed by HTC or whatever. I've quit relying on them since I bought the original EVO though. Sometimes u just gotta fix it yourself or find an app that can.

Sent from OG EVO LTE with Android Central Forums
 

IAmSixNine

Well-known member
Jun 1, 2010
3,157
72
0
Visit site
Is your bluetooth on?
Are there multple wifi hotspots on the same channel?
I notice at work i get multiple disconnects but at home no problems.
At home im the only one on the particular channel. At work there are lots of devices to compete with.
 

k000

Well-known member
May 12, 2012
197
4
0
Visit site
I turn on the phone and use it a bit, I get a notification of 6 or 7 program updates, at least one of which is a large program. I am done with what I am doing, so I launch the Play Store link from the notification. I approve the mass update. I see it download and install a few apps, without touching the screen. It goes to sleep. I walk away. Come back much later and it is pretending to download one of the apps and had zero progress and no error. I stop that one and click on "update" again, approve it and it is immediately downloaded and installed.

This I have noticed too, extremely frustrating as I come back and see blue bars waiting on say 5 apps.. and one pretending to still be downlaodin gand not moving one bit.. However for me magically it would start downloading again afetr 4-5 minutes if I am playing with my phone on the side. I thought somehow it could be a "Play" issue..

I would like to call this a "bug" even if HTC wants to call the other "disconnect while in sleep" a feature...
 
  • Like
Reactions: crxssi

Husker Z

Well-known member
May 17, 2010
186
3
0
Visit site
Go to the advanced settings in wifi and make sure that you have "Always" checked under the "Keep Wi-Fi on During Sleep" menu. It defaults to turning off Wi-fi when sleeping, which saves battery.

If you are streaming music or downloading something and put it down, it will not disconnect it because it won't "sleep".
 

hypercubexl

Active member
May 17, 2012
35
8
0
Visit site
I just tested it leaving some app updates downloading and while the wifi stayed on, the downloads stalled when it went to sleep.

I too am wondering if this is more of a problem the Play store app than the wifi settings.

Have to find something to download in the browser or somewhere else and see if it changes behavior.
 

usguyver

Well-known member
Jul 7, 2010
809
4
0
Visit site
I think some of you my have your power saver made on by accident which will turn of. WiFi and data when screen is off go to the power setting I had this problume on my design that I have right now but turning it to where power saver mode comes on only at a serten % hope that helps

Sent from my PH44100 using Tapatalk 2
 

bntran02

Active member
Oct 13, 2011
33
11
0
Visit site
This is a feature of the phone. Go to Settings->Wifi->Menu->Advanced.

There is an option "Keep Wi-Fi on during sleep" that can be set to:
1) Always
2) Only when plugged in (Default i think)
3) Never
 

crxssi

Linux: The power beneath
May 31, 2010
2,668
155
0
Visit site
Is your bluetooth on?
Yes, but not connected to anything (I leave my headset off when not in use
Are there multple wifi hotspots on the same channel?
No
I notice at work i get multiple disconnects but at home no problems.
At home im the only one on the particular channel. At work there are lots of devices to compete with.
I have same problems at home as at work. And at work I have no access points on the same channel (within range of the others).
 

crxssi

Linux: The power beneath
May 31, 2010
2,668
155
0
Visit site
Go to the advanced settings in wifi and make sure that you have "Always" checked under the "Keep Wi-Fi on During Sleep" menu. It defaults to turning off Wi-fi when sleeping, which saves battery.

Please see my first posting:

"* The default setting of "Keep W-iFi on during sleep" is active (set to "always") and I have never changed it."

And I am about 99% sure that the default is to keep Wi-Fi on During Sleep.

If you are streaming music or downloading something and put it down, it will not disconnect it because it won't "sleep".

Not true with downloading. See my 5th posting:

"I turn on the phone and use it a bit, I get a notification of 6 or 7 program updates, at least one of which is a large program. I am done with what I am doing, so I launch the Play Store link from the notification. I approve the mass update. I see it download and install a few apps, without touching the screen. It goes to sleep. I walk away. Come back much later and it is pretending to download one of the apps and had zero progress and no error. I stop that one and click on "update" again, approve it and it is immediately downloaded and installed."

And this has been confirmed by another user now, too.
 

Forum statistics

Threads
943,972
Messages
6,920,843
Members
3,159,333
Latest member
AnnetteConnor