Win 7 PC No Longer Recognized Inc 2

xxexplosivoxx

New member
Aug 31, 2011
2
0
0
Visit site
Hi, I've had my Droid Incredible 2 for about 3 months now with no problems. Yesterday, I plugged the phone in via USB cable into my laptop, as I have done many times before. But now, when I plug in, Windows gives me an alert that the USB device is not recognized. I've re-downloaded and installed HTC Sync to no avail. On the phone itself, there is no recognition that it has been plugged into a PC, except that it is shown as charging. No ability to select disk drive, charge only, htc sync, etc... Has anyone experienced this? has anyone fixed it? I've been working on this for hours with no luck. Yes, I have tried turning both laptop and phone off and on again.

I should mention that I often use a USB cable other than the one my phone came with. Is this bad? I assumed all USB cables were created equal. Would this cause a problem like this?
 
Last edited:

joggy

Well-known member
Apr 21, 2010
117
6
18
Visit site
I should mention that I often use a USB cable other than the one my phone came with. Is this bad? I assumed all USB cables were created equal. Would this cause a problem like this?

While not necessarily bad it could definitely be the cause of your problems. I've found that the DInc2 is very picky on aftermarket or non-HTC branded USB & charging cables. This is the case with the two DInc2's that I own.

Try using the one provided with the phone and see if that works.
 

xxexplosivoxx

New member
Aug 31, 2011
2
0
0
Visit site
While not necessarily bad it could definitely be the cause of your problems. I've found that the DInc2 is very picky on aftermarket or non-HTC branded USB & charging cables. This is the case with the two DInc2's that I own.

Try using the one provided with the phone and see if that works.
Thanks, but no such luck. I took it into the Verizon store today and they wanted to do a factory reset. Is that wise? I'm not keen on losing all my data. Any other alternatives to try?
 

joggy

Well-known member
Apr 21, 2010
117
6
18
Visit site
I'm not sure why a factory reset of the phone would work. A couple of other things to try if you haven't:

- try a different USB port on the Windows machine
- check your settings on the phone: Menu->Settings->Connect to PC and make sure Ask Me is checked or change the Default connection type to your preferred connection
 

Forum statistics

Threads
944,426
Messages
6,922,772
Members
3,159,553
Latest member
saiid