Working M.IP, DATA, and PPP settings for Optimus V?

dammitman

Member
Mar 3, 2011
13
0
0
Visit site
Okay, so after literally hundreds of attempts at getting M.IP and VM data settings to stick on this Optimus V I have decided to ask here. I have read about settings all over the forum here and elsewhere but cannot get 3G working at all. Maybe some of you out there who have been able to successfully get your data back, either after flashing a Sprint .cab or .kdz to recover from a brick, could help? :)

What originally happened to my OV was I wiped with the latest current CWM Recovery from Tom Manager and after a reboot I had a cold brick. Couldn't access fastboot, adb, nothing but a black screen with LG logo and reboot loop. Since we are missing the VM670.DLL file from Virgin Mobile to restore or reflash from Emergency Recovery, the only way I could get a working usuable phone back was to flash a Sprint .cab in Emergency Mode and root it and flash IHO CWM based recovery and restore from a backup. As we all know it usually wipes out or overwrites data settings from VM's to Sprint's when flashing. I can't get any settings or profiles to stick when either checking them as enabled or unchecking disabled with QPST. I have also tried DFS to no avail, after a reboot.

If anyone here has been able to succesfully write the correct data settings and have working 3G, how can this be done? Thank you all in advance for reading and I am looking forward to hopefully helping other people who have done this as well!
 
Feb 19, 2011
1,971
284
0
Visit site
I haven't gotten data working yet, but did have phone and sms working on sprint zv9 radio before switching to a new phone.
if you use qxdm to tweak the nvitems, you can kind of get settings to stick in qpst. the mip settings want to keep the first profile active though, even though vm has than one inactive.
look here for info on qxdm and the ov,
and here for settings info on vm data.
also, there's some settings in the hidden menus (you can get to them with launcher pro and a stock-based rom) like mms, browser, device activation, etc. which need changed to the right urls for vm service.
like I said, though, I haven't gotten mine working again yet... so I'm limited in the help I can offer.
 

dammitman

Member
Mar 3, 2011
13
0
0
Visit site
Thanks for the reply. Yeah I have indeed tried the QXDM NV items method from mmarz posted here, as well as ##data# on stock ROM. I do believe the major thing is getting the profile 0 set to disabled and 2 set to enabled or checked. 1 always stays enabled and 2 stays disabled in my case no matter what I have tried thus far. The addresses I can write no problem, and everything else looks good from what I read here in the posts for settings in QPST. I would say we both have the same issue here, as well as many others that have done these steps to restore. The latest DFS program seems to read data settings differently than QPST does also but when writing the settings they both do the same with each profile as you mentioned here. If I do find anything more I will post or reply here. It's been a real PITA not knowing how to fix data. Thanks again!
 

fenrix

Well-known member
Aug 30, 2011
210
21
0
Visit site
sorry no luck figuring out how to get a radio.img, although having had flashed a sprint radio I wonder if that is reversible. - maybe only with that dll..
 
Feb 19, 2011
1,971
284
0
Visit site
I might have located the radio+bootloader...
at 0x000002000000 to 0x00000281FFFF
I am looking at firerat's mtd partitioning mod on xda as a way to get at it. If it could be added to the atag data "radio" could be added as a flash_image and dump_image accessible partition.
The various PST tools I've tried might be reading it at a different physical address, but won't write it anyway.
I've tried moving MIP profile 2 to 1, 3 to 2, and 1 to 3 to fix the active/inactive issue... not sure about whether it'll really work, but they at least stay switched and are correctly activated/inactivated.
Also thought about forcing NAM2 instead of NAM1 if that's possible; I bet there's no overwriting defaults in the normally unused NAM info.
right now I have my sprintified OV on zvh radio activated on network!
it gets/sends SMS and voice calls.
no data yet, but I'm still using the data connection on my new OV that's not supposed to be active right now, not sure if that's holding up the provisioning or if it's just a system glitch in my favor. I don't dare disconnect it or turn it off yet for fear of losing data service...
 
Feb 19, 2011
1,971
284
0
Visit site
I haven't gotten data working yet, but did have phone and sms working on sprint zv9 radio before switching to a new phone.
if you use qxdm to tweak the nvitems, you can kind of get settings to stick in qpst. the mip settings want to keep the first profile active though, even though vm has than one inactive.
look here for info on qxdm and the ov,
and here for settings info on vm data.
also, there's some settings in the hidden menus (you can get to them with launcher pro and a stock-based rom) like mms, browser, device activation, etc. which need changed to the right urls for vm service.
like I said, though, I haven't gotten mine working again yet... so I'm limited in the help I can offer.
that's as close as I can point you. sorry.
 

Members online

Forum statistics

Threads
943,870
Messages
6,920,391
Members
3,159,266
Latest member
caroltheresa61