Z3C & AT&T

anon(829886)

Well-known member
Jun 25, 2012
143
0
0
Visit site
My Z3C is due to arrive tomorrow. I want to call AT&T to get my phone up and running. This must be done right? I'm assuming I need to talk with them to get voice and data running properly? I have a nano SIM in my Moto X but I'm not confident that just popping it in will make everything work 100%.
 

Christopher Matthews Jr

Well-known member
Jun 27, 2013
240
0
0
Visit site
My Z3C is due to arrive tomorrow. I want to call AT&T to get my phone up and running. This must be done right? I'm assuming I need to talk with them to get voice and data running properly? I have a nano SIM in my Moto X but I'm not confident that just popping it in will make everything work 100%.

Having worked for AT&T for a long while, I can say most devices come with a SIM card that will be activated as soon as you put it into the phone and fire the device up. They usually come with an activation guide as well.
 

anon(464338)

Well-known member
Aug 29, 2011
1,061
3
0
Visit site
Yeah just popping your old nano will work with that at&t account. Or you can get a new free sim from at&t and just have them put the number you're using to that sim. All will work as before. Done it 4 times with all the Z3c's in my household. Lol

Posted via the Android Central App
 

lindseybp

Well-known member
May 7, 2010
814
1
0
Visit site
Yes I popped my SIM out from my Moto X and into my Z3c and everything works great. No need to call At&t as if they change the IMEI it probably will not recognize the phone as having LTE and classify it as a dumb phone.

I think the us version of the Z3c will be recognized in the imei database.

Posted via the Android Central App
 

Spirk

Active member
May 30, 2013
35
0
0
Visit site
I took my SIM out of my S5, trimmed it down to nano SIM size, and stuck it in my Z3C. Everything worked immediately and I haven't had any problems.

I was getting crappy signal in my house so I called AT&T in an attempt to get a free microcell. They asked for my IMEI so I gave it to them. They said "yep, that's a 4G phone, we'll get a network tech out to test reception in your area."

I got a text saying the investigation of my technical issue is complete but no details. I got a microcell off eBay for $60 and now I have awesome service in my house, even in my office in the basement.
 

Joshua Munoz

Active member
May 6, 2010
27
9
0
www.joshuamunoz.com
My Z3C is working fine on AT&T (my previous phone didn't have a nano SIM, so I got one from an AT&T store)

You might want to go to Settings -> Wireless/Network -> More -> Internet Settings and download the APN settings for AT&T.

Programming non-AT&T devices with the correct APN and MMS data settings - AT&T Support

Did that. Didn't start working until I switched from LTE preferred to WCDMA preferred. Lots of people on XDA were talking about the same issue. Already switched out for an M9. Oh well.
 

Jim Williams

Well-known member
Dec 22, 2012
48
0
6
Visit site
I'm on my 3rd z3c. Poor track record on otherwise excellent phone. First was on t mobile. The other two were/are on att. Never a problem, and I haven't had to change any settings. Pop the sim in, let it do its thing and it's running on lte.

Sent from my D5803 using Tapatalk
 

Forum statistics

Threads
941,253
Messages
6,907,636
Members
3,157,829
Latest member
Fairfax44