1. llasch's Avatar
    So I am on a Macbook Pro and have been following the above steps in the sticky for unlocking my bootloader in an attempt to take that big boy step and root this beeotch.

    When I copy the platform-tools file over into the terminal and then go on with the ./fastboot oem unlock command I get a "waiting for device" prompt and get stuck. Also, after clicking on tools-->android in my sdk folder to get the platform tools folder to appear, 'fastboot' is already a folder inside of the platform-tools folder. I have tried copying and pasting the folder with both the original fastboot in that folder as well as removing that and replacing it with the separate one I downloaded from the same site shown in the mac tutorial sticky video...both still give me the "waiting for device" prompt.

    Someone please help, on top of this being my first time unlocking and rooting I also recently made the switch from PC all of my life to this being my first mac, so I'm still adjusting to that as well. Thanks in advance for your help and patience.
    01-15-2012 11:06 PM
  2. thebizz's Avatar
    Are the drivers installed on your comp if not it won't work as your computer will never see your device

    Edit seems you don't need drivers make sure debugging is checked under development options
    01-16-2012 12:01 AM
  3. Andrew Ruffolo's Avatar
    So I am on a Macbook Pro and have been following the above steps in the sticky for unlocking my bootloader in an attempt to take that big boy step and root this beeotch.

    When I copy the platform-tools file over into the terminal and then go on with the ./fastboot oem unlock command I get a "waiting for device" prompt and get stuck. Also, after clicking on tools-->android in my sdk folder to get the platform tools folder to appear, 'fastboot' is already a folder inside of the platform-tools folder. I have tried copying and pasting the folder with both the original fastboot in that folder as well as removing that and replacing it with the separate one I downloaded from the same site shown in the mac tutorial sticky video...both still give me the "waiting for device" prompt.

    Someone please help, on top of this being my first time unlocking and rooting I also recently made the switch from PC all of my life to this being my first mac, so I'm still adjusting to that as well. Thanks in advance for your help and patience.
    its waiting for your device because its not in bootloader.

    You can type ./adb reboot bootloader (make sure debugging is on on the phone before or it won't work)
    01-16-2012 09:49 AM
  4. llasch's Avatar
    I am in debugging mode and it still says "device not found". Do I enter ./adb reboot bootloader before I try the unlock command?
    01-16-2012 09:55 AM
  5. Andrew Ruffolo's Avatar
    I am in debugging mode and it still says "device not found". Do I enter ./adb reboot bootloader before I try the unlock command?
    if the phone is booted... enter
    Code:
    ./adb reboot bootloader
    when you see the android with open panel type:
    Code:
    ./fastboot oem unlock
    01-16-2012 09:58 AM
  6. llasch's Avatar
    Ok I'll try that as soon as I get out of class. Appreciate the help as this is new territory for me. I'm sure this will be the first of many 'help me' topics I start lol.
    01-16-2012 10:15 AM
LINK TO POST COPIED TO CLIPBOARD