1. GalaxyS3guy40's Avatar
    So I've been looking everywhere, and I haven't been able to find anyone else with this issue I've been having. Before I updated my S3 to Jellybean, I had been using several 3rd party ringtones from ringtone apps I installed onto my phone, using them for notifications and ringtones.
    I was pretty excited after the update cuz of all the nifty little upgrades I'd notice here and there, but after not very long I noticed a rather unusual issue. Several of the 3rd party ringtones I used suddenly just would not work on my phone anymore. If I try to set them as notifications or ringtones, then it just either resets the notification or ringtone to either 'silent' or 'default'; those sounds that were in use when my phone updated are just unavailable, although other sounds from the same 3rd party apps work just fine. It just seems to be blocking those specific ringtones, and I can't for the life of me figure out why it would do that : /
    I've tried uninstalling and re-installing the ringtone apps, but with no success....Anyone else have this issue, or maybe have some ideas on what I could try? I have considered a factory reset, but somehow it doesn't seem like that would solve it :/.....that, and I would just rather not do a reset if I can avoid it.

    Any help would be appreciated, Thanx : )
    05-11-2014 12:50 AM
  2. GSDer's Avatar
    Welcome to the forums!

    What file type are they? Mp3?
    Have you tried using the stock music player to see if they work?

    Sent from my rooted, debloated, deodexed Sinclair ZX-80 running CM -0.001 using Tapatalk
    05-11-2014 01:18 AM
  3. GalaxyS3guy40's Avatar
    Thanks ^_^
    I'm not sure what file types they are, or if they can be opened through a music player....I haven't had any luck finding the sound files themselves, because the sounds are from 3rd party ringtone apps. It seems like the files are all just kinda put together into a single data file, and when I use the app it just opens the data file, sorts it out, and plays it....,but then again that's just an assumption cuz I don't know much about how apps really work.
    05-11-2014 03:03 AM
  4. GalaxyS3guy40's Avatar
    Wow, I can't believe I've fixed it, after months of being bothered by it.....I guess I just needed a sounding board or something, cuz your post made me think of the answer. So, just in case someone else is having this issue, I'll write how I solved it, though it may vary slightly or majorly from phone to phone.
    So for the Samsung Galaxy S3 (and maybe others), whenever a 3rd Party App ringtone or notification is set for use, whether it's for all notifications, or just a specific contact, a separate file is copied from the Ringtone App and stored on the phone; what that means is that if the Ringtone App is deleted, you'll still be able to use the ringtone, and that when you're setting the ringtone, you don't have to get into the Ringtone App to find and use the ringtone. So what happened was that I had been using some of the 3rd Party Ringtones and had them set for different contacts, and when the phone updated it's firmware, the ringtone sound files that were copied to my phone got corrupted or something. So it turns out that all I had to do was go into my phone's file browser, go to where the 3rd party ringtones were copied to, and delete them. For me it was on the Phone's Internal Drive/media/ringtone/
    After they were deleted, the ringtones worked just fine, and......Yeah. I hope this helps somebody else, somewhere....sometime : )

    P.S. I did notice one side effect, which wasn't there before the JellyBean update; though it doesn't seem to create any unreasonable problem. When you set each 3rd Party Ringtones for use, and the ringtone is copied to the phone, then when you set that ringtone from that point on (like if you decide to use that ringtone for a different contact or something) you will no longer go into your 3rd Party App to set it; instead, when you set the ringtone, instead of going into your 3rd Party App, you will go into your Media Storage (for my phone, when I set a ringtone it asks me whether to go into a 3rd Party App, or go into the phone's Media Storage to pick one to use). And if you try to set the ringtone from your 3rd Party App it will give you the same problem I mentioned in my initial post. But this isn't really a problem, because I've found that once the copied ringtone is deleted from your phone's Media Storage, then you can again set the ringtone from your 3rd Party Ringtone App, and it will copy the file to your phone again. So in case someone starts freaking out that after following these instructions, that the ringtone is broken again, then just know that it's not broken, and it's just a bug in the software or something.
    05-11-2014 04:34 AM
  5. GTWalling's Avatar
    You do realize that the S3 was shipped with JellyBean already install. Any Android ver 4.x.x is JellyBean.
    05-11-2014 10:45 AM
  6. GalaxyS3guy40's Avatar
    Hmmm, my mistake. It's just been so long since the problem began, which was after a massive update, I just kinda assumed : /
    The JellyBean update came somewhere around last December or January.

    Thanks for the correction
    05-12-2014 07:21 PM

Similar Threads

  1. Unroot/return to stock guide
    By TomW093 in forum LG G Pad 8.3 Google Play edition
    Replies: 1
    Last Post: 04-07-2015, 11:03 AM
  2. Apps/photos won't move/install to SD card on gs4
    By Tom Sz in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 05-10-2014, 11:27 PM
  3. AT&T Update
    By Greg C in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 05-10-2014, 10:51 PM
  4. HTC DNA: cannot get rid of lock screen after software update today to V4.4.2
    By madridmamacita in forum Legacy Android & Other OS's
    Replies: 0
    Last Post: 05-10-2014, 10:48 PM
  5. Replies: 0
    Last Post: 05-10-2014, 10:25 PM