Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
+ Reply
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  
    AC Question
    AC Question's Avatar
    Guest

    Default Samsung s4 odd battery drainage, overheating and non working SIM card

    Okay, so ive had my Sansung s4 for about a year so far with no problems. although today, i charged my phone up to full battery, and after a couple hours it was working fine but all of the sudden the phone got extremely hot to were it would turn off. when i turned it back on i had realized it had drained my battery all the way from 75% to 10% in less than 30 minutes, i also noticed i couldnt get on the internet, call, text or have any connection at all. i restarted my phone multiple times with no help. i tried updating my phone to see if it would fix the problem, yet, it wouldnt update because it cant see the SIM card. any easy fixes? help is appreciated.
  2. #2  

    Default Re: Samsung s4 odd battery drainage, overheating and non working SIM card

    Welcome to Android Central! Try booting into Recovery Mode and wiping the cache partition: Reset: Samsung Galaxy S 4 | T-Mobile Support

    Also try removing the SIM and reinserting it, to make sure it's fully seated. If you still can't make calls or get mobile data reception, I'd take the phone to your wireless store and ask for a replacement SIM.

Similar Threads

  1. SD card having issues
    By JJJC1110 in forum Verizon Samsung Galaxy Note 3
    Replies: 2
    Last Post: 09-28-2014, 09:13 PM
  2. Samsung Galaxy 5 Video Problem
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-30-2014, 01:24 PM
  3. phone won't respond after prompted upgrade on Samsung Galaxy S5
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 08-30-2014, 12:03 AM
  4. Samsung galaxy s4, problems.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-29-2014, 11:58 PM
  5. My Samsung Galaxy Reverb is taking 5+ hours to boot
    By Spilled_Ink in forum Ask a Question
    Replies: 1
    Last Post: 08-29-2014, 11:52 PM

Posting Permissions