1. AC Question's Avatar
    My 2 kids each have a Samsung galaxy tab 3.0... One connects perfectly to our wifi and picks up others in the area, the other only picks up ours and sometimes registers as out of range even if in the next room to the rooter. When it does connect the signal is poor when the other tablet and all other devices are strong.

    All other devices connect fine with strong connection. Even if this is the only device connected it still has the same problem.

    I have tried WPS connection, disconnecting, restarting, software updates, restarting wifi router etc but nothing helps.

    Any ideas please?
    04-13-2015 04:11 PM
  2. srkmagnus's Avatar
    My 2 kids each have a Samsung galaxy tab 3.0... One connects perfectly to our wifi and picks up others in the area, the other only picks up ours and sometimes registers as out of range even if in the next room to the rooter. When it does connect the signal is poor when the other tablet and all other devices are strong.

    All other devices connect fine with strong connection. Even if this is the only device connected it still has the same problem.

    I have tried WPS connection, disconnecting, restarting, software updates, restarting wifi router etc but nothing helps.

    Any ideas please?
    Make sure the problem device is fully updated: system settings > about Tablet > updates.

    If that doesn't solve the problem then consider a factory reset. Backup your data and sync accounts - apps are available in the play store to save apps and app data - then reset and see if that fixes the problem. Let us know how it goes.
    04-13-2015 06:30 PM
  3. Rukbat's Avatar
    Put the problem tablet on the router. Is the signal strong? (It probably is.) That would mean that the antenna isn't connected. That can happen if it's dropped or jarred too often.
    04-13-2015 11:15 PM
  4. LeannePog's Avatar
    Thanks. it is all up to date... I may try the factory reset.
    04-20-2015 03:10 AM
  5. LeannePog's Avatar
    Thanks. The signal is much stronger on the router so this could be the problem.
    Am I able to fix this myself? It has been like this since we bought the tablet - its not something that has happened over time. Its only a few months old so if I cant fix it I will return it.
    Thanks again.
    04-20-2015 03:12 AM

Similar Threads

  1. Is anyone having problems with Lolipop 5.0.2?
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 04-15-2015, 09:21 PM
  2. How Can You Power Up A Alcatel One touch Fierce With A Broken Power Button .?
    By corey brown1 in forum Alcatel One Touch Fierce
    Replies: 1
    Last Post: 04-13-2015, 10:34 PM
  3. Has anyone tried this method of rooting the Turbo?
    By Bleezy in forum Motorola Droid Turbo
    Replies: 2
    Last Post: 04-13-2015, 09:30 PM
  4. Xbox one.
    By knotjeff in forum Google Nexus 6
    Replies: 1
    Last Post: 04-13-2015, 06:32 PM
LINK TO POST COPIED TO CLIPBOARD