1. AC Question's Avatar
    I have Android's Kyocera Event pay-as-you-go phone through Virgin Mobile and I have very recently reformatted it (like, yesterday).

    The phone was running fine with no glitches until, well, I dropped it. And now it won't stop promoting "Unfortunately, Eco Mode has stopped working. [Ok]". I click 'Ok' and it doesn't even wait until the box is fully closed before prompting me again. Everything else on the phone seems to be working fine, though the insistence of the Eco Mode prompting makes it hard to tell for sure.

    I was able to reformat it again but it didn't fix it. And, following instructions, I wiped my cache partition and rebooted the phone. But nothing. I'm about to reformat it again but have very little hope that it will fix it.

    What am I supposed to do?

    (P.S- I'm tech savvy enough that, given instructions, I can take the phone apart and physically fix anything that I might have knocked loose in the fall. If need be.)
    09-21-2015 09:38 PM

Similar Threads

  1. How do I change my ringtone to my favorite song?
    By AC Question in forum Wallpapers, Ringtones, and Themes
    Replies: 1
    Last Post: 09-25-2015, 05:14 PM
  2. (Verizon) MMS won't load/open using Handcent
    By Vapor916 in forum Moto X (2013)
    Replies: 2
    Last Post: 09-23-2015, 11:27 AM
  3. Replies: 1
    Last Post: 09-22-2015, 02:58 AM
  4. Bluetoothing blu phone to zip fitbit
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-21-2015, 09:08 PM
  5. my wireless charger keeps telling my phone charging paused
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-21-2015, 08:59 PM
LINK TO POST COPIED TO CLIPBOARD