1. AC Question's Avatar
    I have a moto 2nd gen 4 g. Some wifi connections work fine but at two locations, when I connected to the wifi, it showed connected but did not ask for my password and I cannot access the Internet. I have tried to forget the network but it just shows connected every time without asking for a password. I have tried entering the IP address manually and also wiping cache but to no avail. Any help would be much appreciated I have android marshmallow 6.0.
    05-20-2016 04:59 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Do those locations require you to accept terms and conditions on a login website? When connected to one of those networks, what happens if you open the browser and select any URL? Does it tell you it can't connect, or does it redirect to the login page?
    05-20-2016 05:09 PM
  3. smiffy61's Avatar
    Many thanks for replying. When I open my browser it just says it's not connected and says retry. It does not open the login page of the hotel Internet.
    05-20-2016 05:55 PM
  4. Rukbat's Avatar
    At a hotel? Bring the phone to the front desk and ask them to please show you how to connect to their wifi. Act stupid and they'll either connect for you (and you'll see what they're doing) or they'll call someone to fix their router.
    05-20-2016 06:05 PM
  5. smiffy61's Avatar
    Thanks for that. I'd have no trouble at all acting stupid!! This happened at a previous hotel and I have spent hours trying to work it out . I would love to know what the problem is, and the people at the last hotel didn't know, they just kept saying that I was connected but of course I wasn't. It just does not ask for the password no matter what I seem to change or select.
    05-20-2016 06:36 PM
  6. B. Diddy's Avatar
    Have you disabled any system apps? Go to Settings>Apps>Disabled, and make sure you didn't disable an app called CaptivePortalLogin.
    05-21-2016 01:12 AM
  7. smiffy61's Avatar
    Thanks for that. I can't seem to find this app on my phone. Is this an app I need to download or is it an app that should have been on my phone from the start. Is it the app that requests a password for wifi access?
    05-21-2016 07:32 AM
  8. Javier P's Avatar
    Yeah, this is a system app. Have you updated to Marshmallow or still running Lollipop? Just in case.

    Lollipop. Go to settings - apps - scroll the header to the left until you select the 'all' tab - search for this app - tap on it - clear cache and restart the phone. If you can't find it in that tab scroll the header until you select 'disabled', search for it and enabled it back.

    Marshmallow. Go to settings - apps - three dots top right - show system - search for the app - clear cache or enable it back - restart the phone.
    B. Diddy likes this.
    05-21-2016 07:57 AM
  9. B. Diddy's Avatar
    Thanks for that. I can't seem to find this app on my phone. Is this an app I need to download or is it an app that should have been on my phone from the start. Is it the app that requests a password for wifi access?
    Not all devices have it--or perhaps it might be called something different. If you haven't disabled any system apps, then it isn't an issue.
    05-21-2016 11:22 AM
  10. Javier P's Avatar
    I just checked in three different Moto devices and this app is included in all of them (G 2013, 2015 and X Play). I imagine that your model should include it as well.
    05-21-2016 11:43 AM
  11. smiffy61's Avatar
    Thanks. I found the app. The disable and force stop are greyed out. I cleared the cache but to no avail. There wasn't anything the page would allow me to do with the app. I am running marshmallow.
    05-21-2016 02:57 PM
  12. Javier P's Avatar
    I've done a little search and I found just a few reports about this same problem. These are some of the possible fixes.

    - Make sure you have mobile data off, switch aeroplane mode on, back off and try signing in again.

    - Switch Wi-Fi off, clear cache and data for your browser, close all tabs, switch Wi-Fi on and then open a new tab in the browser.

    - Use a different browser like Dolphins.

    - Go to settings - Wi-Fi - three dots top right - advanced - switch 'network notification' on.
    B. Diddy likes this.
    05-22-2016 07:49 AM

Similar Threads

  1. Huawei Watch not updating
    By pvthomas in forum Huawei Watch
    Replies: 1
    Last Post: 05-20-2016, 06:12 PM
  2. How can i make my go sms work on my android phone?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-20-2016, 06:07 PM
  3. My galaxy s6 edge keeps bleeping
    By AC Question in forum Samsung Galaxy S6 edge
    Replies: 1
    Last Post: 05-20-2016, 05:20 PM
  4. Replies: 2
    Last Post: 05-20-2016, 05:13 PM
LINK TO POST COPIED TO CLIPBOARD