11-22-2013 11:25 PM
141 12345 ...
tools
  1. MichelleKwan's Avatar
    Thank you. Your automated system saved me many headaches and bricked phones. Is there a way we can paypal donations to you?
    04-21-2012 08:05 PM
  2. sfhub's Avatar
    Thank you. Your automated system saved me many headaches and bricked phones. Is there a way we can paypal donations to you?
    Glad it worked for you. I don't take donations but enjoy your rooted ZVJ setup.
    04-22-2012 04:28 AM
  3. Drakahr's Avatar
    Hey thank you for all of the hard work, I have a bit of experience, but this still looked a little daunting, but the process was a breeze. I started out with a stock zvd-unrooted and upgraded to the stock zvj-unrooted. following instructions braught it back down to zvd, and used to automated process. installed ginger rom, powermod, and ginger kernel. again everything went without a hitch. my phone is super fast, love the trim of the rom, but I've noticed that the only issue I have is that my download speeds suck, about 1/5th or what I was working with before. I assume this has something to do with the radio. any advice on a soulution to this would be greatly appreciated. Thanks!
    04-25-2012 07:08 PM
  4. doolick's Avatar
    Stuck at pushing update.zip - just hung there for a LONG time.

    I started with stock ZVD unrooted (reverted from ZVH update, tried a ROM or two, then put the stock ZVD back on). I rooted using option A, rebooted the phone, got a backup of my stock config, did a factory reset, wiped cache, etc, then rebooted and started back in with option B, zvj root. Stuck on step A of that....
    04-25-2012 10:26 PM
  5. sfhub's Avatar
    Stuck at pushing update.zip - just hung there for a LONG time.

    I started with stock ZVD unrooted (reverted from ZVH update, tried a ROM or two, then put the stock ZVD back on). I rooted using option A, rebooted the phone, got a backup of my stock config, did a factory reset, wiped cache, etc, then rebooted and started back in with option B, zvj root. Stuck on step A of that....
    Did you make sure USB debugging is enabled? After your factory reset, it was probably disabled.
    04-25-2012 10:31 PM
  6. sfhub's Avatar
    I've noticed that the only issue I have is that my download speeds suck, about 1/5th or what I was working with before. I assume this has something to do with the radio. any advice on a soulution to this would be greatly appreciated. Thanks!
    It might be a login issue forcing you to 1xrtt. Try update profile under about phone.

    If that doesn't help try ##72786# reset in dialer (you'll need MSL)

    It could also be a temporary problem with the tower you are using. The symptoms of that are if you travel around and get decent speeds but they are slow in a particular location.
    04-25-2012 10:34 PM
  7. doolick's Avatar
    Did you make sure USB debugging is enabled? After your factory reset, it was probably disabled.
    says USB debugging connected. I also selected to keep the screen awake while charging. I have not tried disabling/enabling USB debugging or another reboot of the phone. I did terminate the batch file on push: copy2sd-zvj/update.zip -> /sdcard/update.zip and then ran that step again, now stuck at the same place... Would "fix permissions" help this?

    other thoughts... my antivirus is disabled, on Vista does cmd need to be run as admin?

    (update) I've tried a couple of my thoughts out, and didn't get very far, but I did notice a different amount of the update.zip had copied each time - I'm going to give it about 30min and see if it's just slow. This is weird because I just copied my info from the stock 2GB sdcard over to a new 8GB C10 Kingston card, should be fast...


    *** UPDATE #2 ***
    Lord have mercy it started working! I ummm... think I uhhh... terminated the batch, disabled debugging, enabled USB storage, no zipfile at all, disabled USB, rebooted manually to recovery and found stock recovery (zvj I presume), said crap I can't do anything here, rebooted to Android, turned on debugging, hooked up the USB, tried again, and it worked. wtf - moving on... Sorry for wasting your time =)
    04-25-2012 10:36 PM
  8. xcpefrmreality's Avatar
    Just want to say thank you for this utility. Worked flawlessly for me and its so much easier than the method I used over a year ago.
    04-26-2012 08:21 AM
  9. sfhub's Avatar
    *** UPDATE #2 ***
    Lord have mercy it started working! I ummm... think I uhhh... terminated the batch, disabled debugging, enabled USB storage, no zipfile at all, disabled USB, rebooted manually to recovery and found stock recovery (zvj I presume), said crap I can't do anything here, rebooted to Android, turned on debugging, hooked up the USB, tried again, and it worked. wtf - moving on... Sorry for wasting your time =)
    I think your USB connection switched to 1.x mode instead of 2.0 mode. This can happen because of iffy cables or driver issues.

    On USB 1.x it takes a LOT longer to copy the files over.
    04-26-2012 03:46 PM
  10. dreze88's Avatar
    This guide was VERY easy and user friendly. Thank you very much, you are awesome.
    04-28-2012 11:29 PM
  11. Drakahr's Avatar
    OK, did the profile update, no difference :/ Now for the ##72786# to work I know I need my lock code, I've attempted to get the code, but using Android Terminal EMU but when I try getprop ril.MSL I get no results, also tried after entering su. but my prompt in ATE isn't just a simple $ or #, it is sh-3.2$ or # respectively. I assume sh is short for a shell, but anyway any advice would be greatly appreciated.

    Drak
    04-30-2012 04:45 PM
  12. sfhub's Avatar
    OK, did the profile update, no difference :/ Now for the ##72786# to work I know I need my lock code, I've attempted to get the code, but using Android Terminal EMU but when I try getprop ril.MSL I get no results
    Sorry, getprop ril.MSL is something you can do for Samsung. I probably lost track of which forum I was on. To get your MSL you'll need to either get it from Sprint or use CDMA workshop. Probably easier to call Sprint. Ask for tech support. Tell them your data isn't working right and it was suggested you do a ##786# reset, but now it is asking you for a code and you are stuck. They'll give you a 6-digit code, that is your MSL.

    Then do a ##72786# reset from your dialer and enter the 6-digit code. (I had you ask them about ##786# reset even though you'd be performing a ##72786# reset, because it increases you chances they know what you are talking about off the bat)

    Anyway, the difference between the two resets is ##786# reset will reset your Android user data as well as NVRAM. ##72786# reset only resets the NVRAM.
    04-30-2012 05:55 PM
  13. Drakahr's Avatar
    I got the code by calling no problem, I tried the ##72786# it seems to have had a positive effect. I think I want to blow the phone out 1 last time though. I want to know if I have this optimum or if I'm missing something.

    wipe data/factory reset
    wipe cash partition
    mounts and storage
    mounts and storage menu - format system, data, cache
    advance and debugging menu - wipe dalvik cache

    install zip from sd card: GingerRom, PowerMod, and GingerKernel

    reboot system, let sit for 10 minutes or so, reboot again




    Those are what I gathered should be the full processes. If there are any other combination of rom/mod/kernel that might work better for me you can reccomend id love to check them out them. thank you so much for all of your help and what you do here.

    Drak
    04-30-2012 06:45 PM
  14. sfhub's Avatar
    wipe data/factory reset
    wipe cash partition
    mounts and storage
    mounts and storage menu - format system, data, cache
    advance and debugging menu - wipe dalvik cache
    ##786# reset from dialer will do all this for you in one step.
    04-30-2012 08:09 PM
  15. rjcotton's Avatar
    just want to make sure of something. I have the zvh radio with hydro rom beta 2 installed. do I do option B to install the rooted ZVJ.
    05-05-2012 10:39 PM
  16. sfhub's Avatar
    just want to make sure of something. I have the zvh radio with hydro rom beta 2 installed. do I do option B to install the rooted ZVJ.
    You can do that. Since you are using a custom ROM, it is probably better to do the optional factory reset step in the Option B instructions, but if you are comfortable booting into recovery by hand (and performing the factory reset) if it bootloops, then you can skip and see what happens.
    05-06-2012 05:08 AM
  17. Mahalalee1's Avatar
    The instructions could not possibly be more confusing. I'm trying to go from ZVH (rooted) to ZVJ (rooted)


    The command prompt says to do things on your phone...but my xionia won't install "update.zip" from sd card. It's a bit unclear whether everything is done through the USB cable or directly on the phone. When I did it through the command prompt it worked, but the prompt made it sound like I had to do some of the steps manually on the phone.
    05-07-2012 07:35 PM
  18. Lolanerd's Avatar
    Ok so I did Step A and it worked fine with no errors whatsoever. However, when I tried to apply sdcard:update.zip, it says installation aborted. However, at the part I'm at, its supposed to work I think, so idk whats up. I tried rebooting but it just shows kraven's cm9 boot that I had originally. Should I just go straight to part C?
    05-07-2012 07:50 PM
  19. sfhub's Avatar
    The instructions could not possibly be more confusing. I'm trying to go from ZVH (rooted) to ZVJ (rooted)


    The command prompt says to do things on your phone...but my xionia won't install "update.zip" from sd card. It's a bit unclear whether everything is done through the USB cable or directly on the phone. When I did it through the command prompt it worked, but the prompt made it sound like I had to do some of the steps manually on the phone.
    Not sure what you are reading, but there are some steps you do from your PC and some steps you need to do on your phone. The ones on phone are noted by the (R) and (A) prefixes in the instructions. R means done on Phone's Recovery menu. A means done on phone in Android.

    After you run Option B, Step A, you should no longer have Xionia.
    05-07-2012 09:12 PM
  20. sfhub's Avatar
    Ok so I did Step A and it worked fine with no errors whatsoever. However, when I tried to apply sdcard:update.zip, it says installation aborted. However, at the part I'm at, its supposed to work I think, so idk whats up. I tried rebooting but it just shows kraven's cm9 boot that I had originally. Should I just go straight to part C?
    You might need to revert to ZVD first. There is probably some incompatibility between where the script is installing from and CM9.

    If you post the install logs, I can figure out where things are going wrong and fix it. Otherwise, reverting the ZVD might be faster for you.
    05-07-2012 09:14 PM
  21. BigTunaD's Avatar
    I am having some problems. I get to the point where I try to flash the update and when it runs in backup it tells me the verification failed.
    05-08-2012 08:49 PM
  22. epidenimus's Avatar
    I am having some problems. I get to the point where I try to flash the update and when it runs in backup it tells me the verification failed.
    1. Verify the md5sum of the update file before flashing, if an md5sum is provided. This ensures file integrity.
    2. Turn off the signature verification via your custom ROM and flash again.
    BigTunaD likes this.
    05-08-2012 08:54 PM
  23. BigTunaD's Avatar
    1. Verify the md5sum of the update file before flashing, if an md5sum is provided. This ensures file integrity.
    2. Turn off the signature verification via your custom ROM and flash again.
    Thanks for the help. I think I know what I did wrong, however I ended up running over my Opitmus S last night so new one on the way. *Facepalm* EPIC FAIL!!
    05-09-2012 05:16 PM
  24. epidenimus's Avatar
    Thanks for the help. I think I know what I did wrong, however I ended up running over my Opitmus S last night so new one on the way. *Facepalm* EPIC FAIL!!
    You're welcome. I hope that you didn't run over it in frustration and that no one was talking on it at the time...
    05-09-2012 10:03 PM
  25. BobbyJenks's Avatar
    Regarding the CM7.2 or 9 ZVJ Recovery install failure. All I did was flash ThundeRom 1.8.3 and it worked fine. No need to return to stock.
    05-10-2012 10:40 PM
141 12345 ...
LINK TO POST COPIED TO CLIPBOARD