Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 8 of 8
  1. Thread Author  Thread Author    #1  

    Default MOTO G 3G problem

    hi
    The wifi on my MOTO G is able to function ok. However when i switch wifi off, and turn on my 3G , it couldn't connect to the internet , even though the status bar shows 4 bars. android version 4.4.2
    anyone knows how to fix?
    thanks
  2. #2  

    Default Re: MOTO G 3G problem

    Quote Originally Posted by spearow View Post
    hi
    The wifi on my MOTO G is able to function ok. However when i switch wifi off, and turn on my 3G , it couldn't connect to the internet , even though the status bar shows 4 bars. android version 4.4.2
    anyone knows how to fix?
    thanks
  3. #3  

    Default Re: MOTO G 3G problem

    Hey, just disable your sim in dual sim settings and enable it. This may answer your problem. Have great days with moto g as me
  4. Thread Author  Thread Author    #4  

    Default Re: MOTO G 3G problem

    Quote Originally Posted by Rebin J View Post
    Hey, just disable your sim in dual sim settings and enable it. This may answer your problem. Have great days with moto g as me
    thanks. its still the same.
  5. #5  

    Default

    Do you have at&t by any chance?

    Posted via Android Central App
  6. #6  
    paulw3's Avatar

    Posts
    49 Posts
    Carrier
    ICS 4.0.5

    Default Re: MOTO G 3G problem

    Are the Access Point Names (APN) correct for your carrier??
  7. Thread Author  Thread Author    #7  

    Default Re: MOTO G 3G problem

    Quote Originally Posted by paulw3 View Post
    Are the Access Point Names (APN) correct for your carrier??
    yes, called my provider and even guided APN setup. still i can see the bars on the status, but cannot connect to internet. playstore says no connection. web browser also can't surf.
  8. #8  

    Default Re: MOTO G 3G problem

    This sounds like one of the known problems that some Moto Gs have with Kitkat (in some places, connected to some networks - it's a tricky one, or a tricky set of different problems).

    Take a look here, but it's a long thread so don't bother reading it all:

    https://forums.motorola.com/posts/48fb0b8150

    You could try posting about your problem there, giving all thr details asked for. Motorola support people will probably pick it up. Some people have had their problem solved, but not everyone. A lot of hopes are being pinned on the next update of Kitkat, allegedly coming soon.

Similar Threads

  1. Calendar problem
    By Juunas in forum Samsung Galaxy Note 3
    Replies: 6
    Last Post: 08-03-2014, 08:57 AM
  2. 2 Odd Problems with Apps on Galaxy S4
    By zapfrog in forum AT&T Samsung Galaxy S4
    Replies: 5
    Last Post: 05-17-2014, 06:10 PM
  3. How to create a folder on Moto G
    By kimi21 in forum Moto G (2013)
    Replies: 3
    Last Post: 05-07-2014, 03:03 AM
  4. Looking for 3G/2G switch app (Auto selec GMS Only/WCDMA Only)
    By Harish Gupta in forum General Help and How To
    Replies: 1
    Last Post: 05-06-2014, 03:49 AM
  5. Micro Sd car problems
    By jasond43 in forum HTC One M8
    Replies: 2
    Last Post: 05-05-2014, 09:22 AM

Posting Permissions