Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. Thread Author  Thread Author    #1  

    Default Z1 Compact on T-Mobile LTE

    OK, I went into the local T-Mo store and had them try out a sim card to see if I could get on the LTE network. No dice. All I got was 4G, no LTE. The girl behind the counter said this happens a lot when people bring in unlocked phones. Supposedly T-Mo runs their LTE network at 1700/2100 so the Z1c should have been able to get on. Therefore, I am wondering if anyone has had success and if so, did you have to configure some custom settings?

    I am currently on ATT and can only get on the HSPA+ network because ATT runs their LTE network at 700 which the Z1c doesn't support I really want to use this phone on an LTE network.
  2. #2  

    Default Re: Z1 Compact on T-Mobile LTE

    I believe that since it's not a phone made for the US market that it doesn't show lte at the top of the phone. In the rest of the world, 4G is lte so they don't have to designate. You should be able to go into the status and look at the phone signal and it should say lte. My daughter is using it on t-mobile without a problem.
  3. Thread Author  Thread Author    #3  

    Default Re: Z1 Compact on T-Mobile LTE

    That may be. I will try another t-mo location with hopefully sharper techs. It has been more than a week, but I remember when checking the preferred network mode that LTE was not listed in the options.
  4. #4  

    Default Re: Z1 Compact on T-Mobile LTE

    It works fine on mine. Getting 30 to 40 mb down on speedtest. You just have to change the apn settings. By default they are just a general euro setting hence why your not getting the LTE to work here. Follow this T-Mobile APN Settings | T-Mobile 4G APN Settings
  5. #5  
    jjfad's Avatar

    Posts
    21 Posts
    Global Posts
    152 Global Posts

    Default Re: Z1 Compact on T-Mobile LTE

    Quote Originally Posted by Huitlacoche View Post
    OK, I went into the local T-Mo store and had them try out a sim card to see if I could get on the LTE network. No dice. All I got was 4G, no LTE. The girl behind the counter said this happens a lot when people bring in unlocked phones. Supposedly T-Mo runs their LTE network at 1700/2100 so the Z1c should have been able to get on. Therefore, I am wondering if anyone has had success and if so, did you have to configure some custom settings?

    I am currently on ATT and can only get on the HSPA+ network because ATT runs their LTE network at 700 which the Z1c doesn't support I really want to use this phone on an LTE network.
    Do you have the international version or the one that Sony just announced in their U.S. store?
    Unlocked Sony Xperia Z1 Compact sales begin in the U.S. | Android and Me
  6. #6  

    Default Re: Z1 Compact on T-Mobile LTE

    I didn't have any problems. When I first got my phone, I just put my T-Mobile SIM in it and it automatically downloaded all the settings and I had LTE. I am in Southern California. the APN should be fast.t-mobile.com

Similar Threads

  1. Sky Go on Samsung Note 3
    By Andrew Walton1 in forum Samsung Galaxy Note 3
    Replies: 7
    Last Post: 05-01-2014, 04:23 PM
  2. After update 4G symbol is back when on a wifi..
    By CypherMax in forum Verizon Samsung Galaxy S4
    Replies: 8
    Last Post: 04-29-2014, 10:07 AM
  3. Z2 coming to T-Mobile??
    By marshatherton in forum Sony Xperia Z2
    Replies: 3
    Last Post: 04-25-2014, 08:38 PM
  4. Replies: 5
    Last Post: 04-25-2014, 08:17 PM
  5. Adding YouTube to Kid's Mode on Galaxy S5
    By trishandtim in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 04-25-2014, 03:27 PM

Posting Permissions