1. f1nzup's Avatar
    For those that are being prompted for the Premium Service and get kicked out of the app when you decline, this is a known issue for Telenav. I called them and they said this is a known issue and they are working on the problem, but do not have an ETA of when it will be fixed. They are supposed to let me know when it is fixed and I will try and relay that information here. In the meantime he said to periodically check the app to see if it is fixed. This is just an FYI for anyone else experiencing this problem so that they don't spend a lot of time like myself trying to figure what is the problem.
    dad2noah and jerseygirl like this.
    08-09-2012 02:45 PM
  2. dad2noah's Avatar
    I factory reset my Sammy last week, and opened up the telenav last night for the first time. I was like wtf?
    The google maps navigation still worked, which I like better anyway, so I wasn't sweatin it. Glad to hear it's not just me though.
    08-09-2012 04:56 PM
  3. sparksd's Avatar
    Just started seeing this, too. When I first read about this problem a day or two ago I checked my phone and it was fine. Not today, though.

    Dave
    08-09-2012 08:40 PM
  4. jerseygirl's Avatar
    Glad to hear that the app is still free. I've been getting kicked out the last few times I tried to use it because I refused to select a pay option.
    08-10-2012 07:20 AM
  5. cgardnervt's Avatar
    Question for you Sprint folks!

    Telenav is under my app list from where I used to be a Sprint customer with the Evo line. It says right now that I can download it on my AT&T S3...Think this would work or would it screw up my GPS?

    Sorry to take this off topic!
    08-10-2012 07:44 AM
  6. maaavy's Avatar
    For those of you still having the problem.
    If you have uninstalled TeleNav make sure you install it again.
    Go to settings.
    Click on apps.
    Go to TeleNav.
    Click on clear DATA.
    Go to settings.
    Go to system updates.
    Click on Update profile.
    Go back to TeleNav and enjoy once again.
    f1nzup and CaLovitt like this.
    08-12-2012 11:58 PM
  7. f1nzup's Avatar
    That did it. Thanks!

    Sent from my Samsung Galaxy S3
    08-13-2012 05:45 AM
  8. sparksd's Avatar
    Another fix posted at Sprint's forum worked for me --

    When you start it up, click on the url link to terms and conditions for use. Then click the accept button.

    That brings you to the screen with the choice to upgrade or continue using the free version.

    Dave
    08-13-2012 05:47 AM
  9. steveh552's Avatar
    Why use a paid service when Google is free?

    Sent from my SCH-I535 using Android Central Forums
    08-13-2012 06:03 AM
  10. f1nzup's Avatar
    Why use a paid service when Google is free?

    Sent from my SCH-I535 using Android Central Forums
    Telenav has always been free too, and personally I like the navigation better than Google. They both have their upsides, but when I have to actually navigate, I prefer Telenav. For me it just looks better, but that is always going to be personal preference.
    08-13-2012 07:01 AM
  11. steveh552's Avatar
    Fair enough. I thought it was a paid app.

    Sent from my SCH-I535 using Android Central Forums
    08-13-2012 07:02 AM
  12. Skunkape60's Avatar
    Fair enough. I thought it was a paid app.

    Sent from my SCH-I535 using Android Central Forums
    certain functions are only available with the paid version. While I liked the map better with Telnav. The new Google navigation can be used without a data signal. This makes it a much better choice when navigating in areas without or with a poor data signal.
    08-13-2012 01:52 PM
  13. CaLovitt's Avatar
    @maaavy - Thanks a bunch! Clearing DATA worked. I was about to sign up for the premium service
    11-16-2012 10:25 AM
LINK TO POST COPIED TO CLIPBOARD