1. aapold's Avatar
    it installs fine for me, lets me browse apps. When I click "install", nothing happens.

    I've side-loaded plenty of apps, no trouble.

    Is there more than one version of getjar?
    11-19-2011 10:19 AM
  2. DirkBelig's Avatar
    The first night I used GetJar, it said there were no apps for the Fire, but last night I used it to load Nook for Android. Haven't tried anything else yet.
    11-19-2011 11:59 AM
  3. cmcalpine55's Avatar
    Having trouble with Getjar also. Downloaded it once, and it allowed me access to get the Nook app, then tried to get the go launcher ex app and it wouldn't install [clicking download did nothing]. Un-installed and re-installed Getjar still no luck on clicking download for go launcher ex.
    11-23-2011 05:50 PM
  4. adamkesher's Avatar
    I used it to load Nook and Kobo, worked fine. All of the other "apps" seemed to be mobile sites. So stupid you can't put Facebook for Android on it.
    11-23-2011 05:55 PM
  5. PookaLady's Avatar
    I just downloaded it last night and it worked fine or me.You might want to try again.
    12-06-2011 12:10 PM
  6. aapold's Avatar
    Guess I hadn't updated here. Plenty of other apps have since worked with it for me including the nook reader..
    12-07-2011 07:36 AM
  7. bigd2375's Avatar
    I have two Nextbook tablets and the damn system is not working!!!!! The kicker is that no one answers the phones over there or emails!!!!!! This system bites!!!!
    12-26-2012 01:23 PM