04-13-2018 02:42 AM
168 123 ...
tools
  1. Braulio1228's Avatar
    I updated my t-mobile galaxy S5 to Android 5.0 close to a month ago, setup smart lock with my home as a trusted place and it worked for about week and a 1/2, I still have the same settings (trust agents enabled, my address as a trusted place and pattern lock on) but it doesn' t work anymore. I haven' t installed any screen lock app or any that would do anything to my screen. The lock at the bottom of the screen when locked
    doesn' t show anymore.
    AnnDroid and EllaMc like this.
    03-07-2015 10:22 AM
  2. Greggies79's Avatar
    Same thing was happening on my 2014 Moto X running android 5.0 all I did was go into Google play services and uninstall updates and then the phone prompted me to install the new update afterwords, I went into the security settings and reset the smart lock info and restarted my phone, afterwards everything worked
    03-07-2015 04:17 PM
  3. scuttlefield's Avatar
    Thanks. I was having the same problem. I had manually installed an update to Play Services. Uninstalling updates and reinstalling fixed my problem with Trusted Places as well.
    03-09-2015 05:23 PM
  4. unashamedgeek's Avatar
    I updated to 5.1 today from the Google provided image and my trusted places isn't working. I can add a place, but it doesn't unlock while I'm there. I did a factory image flash.
    03-10-2015 04:37 PM
  5. mzanette's Avatar
    Same experience for me. Trusted places on my Nexus 5 worked great in Android 5.0.1, but now after updating to Android 5.1, it no longer works. Face unlock is fine though. Annoying that they broke this feature which I use all the time.
    03-10-2015 06:52 PM
  6. WillJitsu's Avatar
    Same issue here. Trusted Places is not working on my Nexus 5 running Android 5.1. This was working fine in previous versions of Lollipop.
    03-10-2015 10:27 PM
  7. Braulio1228's Avatar
    I tried unistalling and reinstalling updates on Google play services, like in a previous comments, but that didn't work for me.
    03-11-2015 12:48 AM
  8. unashamedgeek's Avatar
    Some times when I go into the trust places setting to confirm everything is working properly, when I click on my home location, a message will pop up stating that Google Play Services has stopped working. I can't uninstall any Google play service updates, that option is grayed out for me.

    Update: Just installed Google Play Services 7.0.93 and still no luck.
    Update 2: After installing the latest version from apkmirror, I rebooted and went back into the trusted places settings. I turned off my Home location. Then added a place and used maps to pick my location again (it auto found it) and selected it. Then I made sure Home location was turned back on and now it appears to be working for me.
    Colin Meredith likes this.
    03-11-2015 08:17 AM
  9. chrdesl's Avatar
    Hi,

    same problem with my home-address. It's working fine at my "Work"-Address. Anyone uses 2 Google Accounts?
    03-11-2015 09:08 AM
  10. y2whisper's Avatar
    Here is what worked for me on my N6 and N9.

    Turn off smart unlock on your home and work and remove any other addresses.

    under security in the advanced section choose trusted agents
    Turn off smart unlock
    back out (might not be necessary)
    go back in and turn it on

    Now add back in your addresses.

    Hope this helps.
    03-11-2015 02:52 PM
  11. ACADM's Avatar
    I've just got this problem with my Nexus 5 on Android 5.0.1.
    It was working fine until a few days ago when it just stopped working without me doing anything to the phone.
    I also get the Google Play Services error pop-up when I click on my home address in Trusted Places, and I don't see a way of deleting it only editing it? Also the Uninstall Updates button is greyed out in Google Play Services, so I can't do that either. The lock button on the home screen still has a pulsating ring around it so that can't be a problem either.

    It's so frustrating when something stops working for no discernible reason.

    Posted via Android Central App
    lemonsarenice likes this.
    03-14-2015 12:46 PM
  12. gkendall43's Avatar
    I have the same problem on 5.0.2 on my Nexus 7. It just started happening recently. I have been getting error notifications that take me to Google Play Services lately but when I go there I can't find anything to fix.

    Posted via Android Central App
    03-14-2015 03:24 PM
  13. SactoKingsFan's Avatar
    Here is what worked for me on my N6 and N9.

    Turn off smart unlock on your home and work and remove any other addresses.

    under security in the advanced section choose trusted agents
    Turn off smart unlock
    back out (might not be necessary)
    go back in and turn it on

    Now add back in your addresses.

    Hope this helps.
    This is exactly what I did to get smart lock working on my G2.

    Sent from my LG-G2 running Vanir 5.0.2
    03-14-2015 04:07 PM
  14. Kimnaii's Avatar
    Hi there,
    I have had the same problem and when following all the suggestions on this forum I found out that two of my apps are overwriting the Smart Lock app. If you have apps such as Outlook and/or and Anti-virus (I've got McAfee) then it "could" be the reason why Smart Lock stops working. I will have to wait until I get back to my trust place this evening to see if it worked after deactivating Outlook for Android and McAfee (both required for work but if this is the problem, then I will reconsider having these on my phone).
    I hope this helps.

    Updated PS: Smart Lock however still works when in my car while connected to Bluetooth...strange, huh?
    03-16-2015 08:06 AM
  15. Kimnaii's Avatar
    OK ... so still does not work. It is these apps that override the Smart Lock feature.
    03-17-2015 04:25 AM
  16. dtungsten's Avatar
    None of the suggestions worked for me, but it mysteriously started working again this morning. It wasn't a Google Play Services update, either. No telling if it will keep working or not.

    Edit: I just realized that it was working because I had a trusted Bluetooth connection, so I expect it is still broken for me.
    03-17-2015 08:22 AM
  17. Shilohcane's Avatar
    Hi,

    same problem with my home-address. It's working fine at my "Work"-Address. Anyone uses 2 Google Accounts?
    Google Maps is off on my home address and GPS location on their map. So if I use just my home address it isn't where Google thinks my Smart Lock is at.

    I was using the other and using GPS to pin point where I live for Smart Lock then it occurred to me that I was just wasting battery since it's not that hard to just do the Pattern Lock. Smart Lock isn't ready for prime time in my opinion.
    03-17-2015 08:57 AM
  18. dtungsten's Avatar
    I just tested the feature by adding another location, and it worked there. So in my case, it seems to be a problem with the location in question, and not with trusted locations in general.
    03-17-2015 01:37 PM
  19. redlaber's Avatar
    Nothing helps for me. Still not working :-(
    03-17-2015 02:41 PM
  20. lion7718's Avatar
    Not working for me either, but I've noticed I'm not seeing the 'location icon' on the lock screen or after I wake it up anymore.
    Nexus 4 w/5.0.1
    03-18-2015 06:36 AM
  21. isewise's Avatar
    I just tested the feature by adding another location, and it worked there. So in my case, it seems to be a problem with the location in question, and not with trusted locations in general.
    Did same thing. Added my work location and it works fine, but my home address is not working. I've tried just about all previously mentioned suggestions.
    03-18-2015 04:18 PM
  22. Jeroen Nootebos's Avatar
    This helped me out on N6, thanks!
    03-19-2015 04:23 AM
  23. Jeroen Nootebos's Avatar
    Here is what worked for me on my N6 and N9.

    Turn off smart unlock on your home and work and remove any other addresses.

    under security in the advanced section choose trusted agents
    Turn off smart unlock
    back out (might not be necessary)
    go back in and turn it on

    Now add back in your addresses.

    Hope this helps.
    This helped me out on N6, thanks!
    03-19-2015 04:25 AM
  24. lion7718's Avatar
    03-19-2015 06:42 AM
  25. dtungsten's Avatar
    Yep, mine just doesn't work at the physical location of my home any more. I even changed my home location to something else and added my address as a separate location. I think nothing short of a factory reset will work for me, and even then maybe not. I give up on it for now, but if it does start working again, I'll post.
    03-19-2015 07:34 AM
168 123 ...

Similar Threads

  1. When my screen is unlocked why doesn't anything show?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-08-2015, 01:34 AM
  2. Replies: 2
    Last Post: 03-07-2015, 12:47 PM
  3. Replies: 2
    Last Post: 03-07-2015, 08:56 AM
  4. Replies: 1
    Last Post: 03-07-2015, 08:52 AM
  5. google play not working/android.media.process.stopped
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-07-2015, 08:51 AM
LINK TO POST COPIED TO CLIPBOARD