1. JunoKorea's Avatar
    Hello Android Users!

    I have recently downloaded Chrome Mobile on my GS2.

    I live in Korea.

    Because of this, Chrome Mobile chose my default search engine as Korea. But I want Google English, it is better for search results.

    I went to settings. I selected "Search Engine" and I have 3 options... Google (google.co.kr), Yahoo.com, and bing.com.

    How can I change this?

    Thank you.
    07-10-2012 09:22 PM
  2. Kilroy238's Avatar
    I'm in China and would love an answer to this as well.


    Any updates?
    08-06-2012 12:15 PM
  3. livne's Avatar
    I encountered the same problem and I found a solution.
    For this solution to work you need to have root access to your phone.
    Open the file manager (you'll need one that supports root), from the root location go to the "data" folder where you'll find another "data" folder so click on it.
    Then locate the chrome folder (com.android,chrome) and in this folder enter the app_chrome folder.
    You'll see there a file called Local State so open it, if you get the notification "no activity found to open this file choose "Open as...", there select "Text file" and select a text editor from the list.
    At the top you'll find "last_known_google_url":"http://www.google.co.kr/" so change the.co.kr to .com (or in the case of China: change the .cn to .com)
    Do the same in the second line ("last_promped_google_url":"http://www.google.co.kr/")
    Then save the file.
    After saving this change open chrome again and do a search, this time it will search in Google.com but a notification will appear asking if you'd like to use the local site instead of Google.com so click, of course, on "keep using Google.com".
    From now on all your searches will be made with Google.com.
    08-16-2012 10:10 AM
  4. brinraeven's Avatar
    OK, but I'm not rooted and don't want to be.
    08-28-2012 11:51 PM
  5. Ahmad Shishani's Avatar
    Well, I've been aching to find a solution for this and I did ironically it is simple, go to menu --> settings --> Accounts --> Choose Google --> you'll get Options to choose -->within privacy options choose search --> Tick ON search "on google .com" once done exit settings go to chrome change to bing.com, search for something then switch back to Google as default search engine, back to chrome type anything to search in the address bar and you'll get that magical yellow pop up message telling to use Google.com instead of your local one. TARRRRAAAAAA you're done, to make sure check default search engine in chrome settings you'll see it has been switched to Google.com
    Hope it will work for you
    08-14-2013 04:39 PM
LINK TO POST COPIED TO CLIPBOARD