1. Android Central Question's Avatar
    I am facing this problem on my INFINIX NOTE 7 LITE from around 6 hours.
    06-20-2021 10:59 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! I assume nothing is connected via USB? Does this persist after a reboot, or in Safe Mode? https://www.hardreset.info/devices/i...ite/safe-mode/

    Make sure the phone's USB port is completely clean -- use a can of compressed air to blow it out, and a dry toothbrush to scrub the inside of it.

    Please register on this forum, which will allow you to engage in discussion more easily, as well as post images. https://forums.androidcentral.com/as...community.html
    06-20-2021 11:22 AM
  3. mustang7757's Avatar
    Definitely would try the recommended Safe Mode
    06-20-2021 05:44 PM
  4. rgmward's Avatar
    i am having the same issue with my Nokia X20 since 2 days
    not possible to charge or connect any devices

    safe mode did not help, and there is nothing in the charging port (but i did try to clean anyway)
    07-06-2021 07:21 AM
  5. mustang7757's Avatar
    i am having the same issue with my Nokia X20 since 2 days
    not possible to charge or connect any devices

    safe mode did not help, and there is nothing in the charging port (but i did try to clean anyway)
    Go into settings >apps>system apps >scroll to you find usb settings then tap clear data and force stop it , see if that helps if not then most likely going to need see a repair center.
    07-06-2021 09:43 AM
  6. Alladin Aziz's Avatar
    same issue facing on my Samsung note 10 after update..
    11-03-2021 04:20 AM
  7. jstewa22's Avatar
    same issue facing on my Samsung note 10 after update..
    I've had the same issue since the last Android OS update, maybe two months ago; the problem has been appearing randomly once or twice a day, no obvious precipitant, and it prevents charging or connecting to my desktop via a USB cable. I have a Samsung Galaxy A21, running Android 11. Lots of posts out there about cleaning the USB port, but nobody has reported success with that (myself included) and it doesn't make a lot of sense anyway, especially since the problem appeared right after an OS update. I did try force-stopping and clearing the data for the USB Settings system app, that seemed promising but didn't work.

    There are lots of posts in lots of forums about this problem, nobody seems to have found a solution. I can reboot the phone or reboot and clear the cache, that solves the problem for a few hours and I'm able to charge and to move files to and from the desktop, but that's obviously not how I'd like it to be.

    Anyone who has found a durable solution (i.e., that works for more than a day or two), we're all ears. Thanks!

    03-31-2022 06:54 AM
  8. B. Diddy's Avatar
    Welcome to Android Central! I read through this thread again and realized that the OP may have been referring to a feature that allows the phone to charge another device via USB -- is that what you're seeing as well?

    Also, does this happen in Safe Mode as well? https://www.t-mobile.com/support/dev...ung-galaxy-a21
    03-31-2022 09:45 AM
  9. jstewa22's Avatar
    B. Diddy, I think that's what the problem means, i.e, I think the phone believes that it's charging an external device, and the options to switch control don't work. I've done far more digging into this than I ever thought I would need to; it seems to be a common problem and nobody seems to have posted a definitive solution. I've tried a lot of ideas.

    However. I think I may have found something, although this might just be coincidental. Someone on some forum or other suggested: settings/apps/system apps/Android System/clear cache, then reboot the phone. In the past, simply rebooting or clearing the cache partition and restarting has invariably corrected the problem for a few hours, maybe 3/4 of a day, and that's what I expected with this; since the last OS update, I"ve never gone an entire day without the problem. However, the problem has been resolved for about five days now. On two or three occasions, I've seen the problem/notification appearing and then going away on its own, after minutes to maybe an hour; I'd never seen it self-correct before. Again, this may all be coincidental (just like the clean-the-USB-port solution seems to be), but this is the longest I've gone without the issue in several months.

    I'll post again if I learn anything new. Thanks to everyone here!

    B. Diddy likes this.
    04-06-2022 08:00 AM
  10. jstewa22's Avatar
    Good morning, wanted to follow up on the above issue, please refer to my 3/31/22 and 4/6/22 posts; briefly, I've been struggling with this same problem for a few months, getting the notification randomly about once per day and unable to charge or connect to my desktop via USB cable until restarting (plus or minus clearing the cache) my Galaxy A21. As noted above, on 4/1 I went to settings/apps/system apps/android system, cleared the cache and restarted. Might be coincidental but I haven't had the problem in the last 19 days. On three or four occasions, the notification reappeared, but it disappeared on its own within minutes, without my doing anything at all, and I've had no problems at all since. There's been one OS security update, maybe 10 days or so ago, but the problem is still resolved. Fingers crossed; I'll re-post if the problem arises again, but no problems for 19 days now.

    B. Diddy likes this.
    04-20-2022 06:42 AM
  11. japeyelnoc's Avatar
    Brand new here at And Cent. I've just started noticing this too. It first happened last Friday. I found the temp fix noted above about clearing the Cache on Android System. But now it's happened for the 4th time. It's a Moto Z4. I'm at QDF30.130-42-5-17, updated back in January, and showing a Security patch level of Sept 1, 2021. So mine looks to be unrelated to an update. Also, my wife has an identical phone, but hasn't had it occur at all, which adds to the puzzle.

    So, not much to contribute beyond my deets. More just jumping in so that I'll see if anyone finds a solution.

    05-17-2022 06:31 AM
  12. jstewa22's Avatar
    Hi, japeyelnoc, thanks for posting your experience. Well, I think it's obvious from all the posts, here and elsewhere, that this is a relatively common issue and not limited to any particular make and model of phone. Not sure if it's limited to Android 11, I'd have to look back, although this has been reported for several years so it's probably not. So far, there have been no definitive solutions posted. Some Samsung employees have posted and have simply said that the phone should be sent back to Samsung for repair; some people have done that, paid a lot of money and the issue has remained. Not sure if representatives of other phone manufacturers or of Google/Android have posted the same totally useless advice.

    For what it's worth. See my 3/31, 4/6 and 4/20 posts above. I'm using a Samsung Galaxy A21 running Android 11, I had the issue and had to reboot about once a day since maybe December or January; I tried the above-noted solution (settings-apps-show system apps-Android System-storage-clear cache; then reboot) on 4/1, since then I've only had to reboot once (after clearing the Android System cache again), so I consider this a fairly durable (although not understood) solution. The problem shows up from time to time if I look at notifications, but disappears on its own after maybe ten to thirty minutes.

    I sure wish I understood what's going on here, or had a more definitive solution, but I'm happy now.
    05-18-2022 04:56 AM
  13. japeyelnoc's Avatar
    Morning, jstewa22,

    Thanks for the reply. Unfortunately, even after trying the clear cache fix it's getting worse and worse for me. It happens more than once a day now! So now I just wait until I need to charge it, then I clear, reboot, and plug it in. FRUSTRATING!!!

    We're holding out right now, waiting for the soon-to-come 3rd gen Razor (Maven, whatever). If that turns out to be a good phone (fingers crossed), that's our next one. If not, well we're still about ready for a change.
    05-19-2022 06:49 AM
  14. jstewa22's Avatar
    Sorry to hear that it didn't work for you, japeyelnoc. I think it's remarkable that this problem has been reported again and again for the past several years and that the Android developers and customer service people haven't made any effort at all to offer a solution, or even an explanation.
    05-20-2022 04:45 AM
  15. japeyelnoc's Avatar
    I saw a post about this elsewhere and the person said it was a dirty connector on their phone. They gave it a good cleaning and never saw the problem again. That could to a degree explain why I had the problem and my wife (identical phone) didn't. OTOH, I cleaned mine but no joy.

    In the end, since it was happening multiple times a day, I gave up and used my insurance to get a new one.
    05-23-2022 06:13 AM
  16. jstewa22's Avatar
    Sorry, japeyelnoc; I'm glad that you had insurance and could get a new phone (although moving over to a new phone is always a hassle). Please post here if the problem arises on your new phone. I'm not sure how common this is, but there are plenty of threads about it, dozens of people have posted about it and there are certainly many who don't; I don't know what the denominator is.

    I've seen many, many posts about the problem being related to a dirty USB port, I think it's just parroted by many people. Throughly cleaning the port (with a headlamp, magnifier, plastic probe and alcohol pad) didn't work at all for me, not even for a couple of days. The only way I could see that being the cause is if the dirt were somehow shorting some of the contacts in the port, and it would be easy to reproduce the problem by putting a piece of foil or other conductor in the port. I haven't tried that.

    Anyway, the problem remains resolved on my Galaxy A21 for almost two months now, maybe my solution worked for me, anyway. I don't think it was coincidental (see my previous posts). There are a few posts about the problem magically going away without any intervention at all. I sure wish someone with some knowledge about this would post somewhere.
    05-24-2022 05:44 AM
  17. jstewa22's Avatar
    One more update: the problem remails completely resolved on my Galaxy A21. There have been one or two Android system updates (still have Android 11) since my May 24 post, and I haven't seen the problem once since then, not even showing up for a few minutes and resolving on its own. Not sure if anything in the updates has addressed it (I'll be curious about others' experience) or if my solution (settings/apps/show system apps/Android system/clear cache, then reboot) has been durable.

    Anyone still having this problem? Has it gone away?

    06-20-2022 07:22 AM
  18. japeyelnoc's Avatar
    Here's my update: Asurion sent me a replacement Moto Z4. It was fine for 4-5 weeks but then the problem resurfaced! And again, so very odd that my wife's Z4 is still fine - she's never had it occur.

    (For those that didn't see my earlier posts, my first (and then later 2nd in June) Z4 developed the problem in May. It started out infrequently then got to more than once a day. The "clear cache on Android System and reboot" only cleared it for a short time. In fact, sometimes I had to plug into a charger during the reboot to get it to clear. And the clean contacts didn't do a thing.)

    Well, Asurion warrants for 12 months so I called to get a replacement replacement (r^2 ?). After explaining what was happening, they offered to send me a different model, which I'd not realized was an option. So I said sure. They sent a Motorola One 5G UW. Got that set up Sunday. 3 days in and it's fine, but I'm still wondering.
    06-22-2022 06:20 AM
  19. jstewa22's Avatar
    Sorry to hear that, japeyelnoc, sounds horribly frustrating. Nobody else has been responding to this thread over the last few months; I'm wondering if the problem is going away, or has been addressed by any of the Android updates. I specifically wonder if that's why I'm not seeing it anymore. japeyelnoc, you were still running Android 11 on your replacement phone? Updates didn't make it go away? Let us know if the new Motorola One stays healthy.

    You know, someone has to understand where this problem is coming from, like maybe some of the Android software engineers. Sucks that they haven't addressed it anywhere.
    06-23-2022 07:55 AM
  20. IsbellDL's Avatar
    I have the following phone:
    Ulefone Armor 9
    Android 10
    Security patch level November 5, 2020
    Google Play system update 2022-06-01 Q
    Build Number Armor 9_TF1_V02
    USB-C charging port
    My phone just started having this problem yesterday. I did discover that I can restart while plugged in to charge, so at least my phone is still usable. I tried clearing the cache for Android System & restarting, as well as safe mode. Neither changed anything. My phone has a rubber cover over the port. I've also only had it for a bit over a year. It shouldn't be dirty enough to be an issue, but I did clean it with a can of air. That didn't help either. I will be trying IPA and a toothbrush next, but I don't expect any change. The phone hasn't received any updates other than Google Play and related apps since the first ones just after purchase (yay abandoned Chinese Android software...), so I don't think updates are likely to be the cause. My first instinct is that it may be hardware related. I swear it used to make a light click when plugged in, but it doesn't feel like the plugs latch properly anymore. They still do on my XBox controller for reference. I'm not sure what my next troubleshooting step should be when cleaning with IPA inevitably fails. I hope my information helps work towards a cause and potentially resolution though.
    07-04-2022 09:05 PM
  21. jstewa22's Avatar
    Sorry you caught this plague, IsbellDL. I'm still problem-free, after about four to six months of at least daily problems, not sure why I got so lucky. I really don't think it's a problem with a dirty USB port, a thorough cleaning (with isopropyl alcohol and a thorough scrub under a maginifier) didn't make a difference; I think that's just a rumor that people parrot, and the problem is so random that it can appear to have fixed it, at least for a few days. It's frustrating that, with all the reports of this same problem on all different devices, the Android developers haven't done anything about it, nor even posted an explanation.
    07-05-2022 08:20 AM
  22. B. Diddy's Avatar
    I would guess that this is a hardware issue, rather than something to do with the firmware or software. It may be that something in the USB port contacts is sending a false signal that makes the phone think it's connected to another device, thus triggering the Charging Connected Device message. If there's no option in the system settings to completely turn off the ability to charge connected devices, then I suspect the only other solution would be to replace the USB port (which would require a repair shop).
    Laura Knotek likes this.
    07-05-2022 09:35 AM
  23. IsbellDL's Avatar
    Yeah, faulty USB was my first suspicion. No longer locking to the cables contributes to that thought. Can anyone confirm if this only USB-C devices or has it happened with Micro USB as well? Edit: just looked up some of the other phone models mentioned with issues. At least one shows as having Micro USB. Still proceeding under assumption of hardware issue as software steps have made no difference for me.
    My phone is such an oddball device that I'm not convinced local repair shops will be much help. I've been getting into soldering and modding old consoles. I'm considering opening it up myself to see if I can figure anything out. Will probably be a while before I have time to do so, but I'll update with any findings if I'm able to get into it.
    So, looks like the back comes off just with some screws, and the charging port is only a couple more screws and a ribbon cable. I'm ordering a replacement on Ebay (fastest shipping option I found) to test. I'll let everyone know how it goes. It may be the end of July before I have a part to try with.
    B. Diddy likes this.
    07-05-2022 09:01 PM
  24. jstewa22's Avatar
    Thanks for the input, B Diddy and IsbellDL. I'm not software or electrical engineer and I'm just guessing (unfortunately, we all are since the Android developers haven't weighed in on this; my guesses are probably a lot less educated than others', though). It seems that if the problem were caused by a defective port, it would be far more common in certain makes and models of phone, but it sure doesn't seem that way. Likewise, if the problem were caused by dirt (perhaps conductive dirt; it wouldn't be insulating dirt since the problem occurs when not plugged in) in the port, more people would be reporting cleaning the port as a durable solution. Truth be told, I haven't seen anyone who reported success with cleaning the port coming back and saying, "well, the problem is back." If the problem were caused by conductive dirt, couldn't it be reproduced by trying to short some of the contacts with a piece of foil or something?

    For what it's worth, I had no luck with thoroughly cleaning my (USB-C) port, but have been problem-free since early April, after clearing the Android System cache in settings/apps (see above).

    I really appreciate the discussion!
    B. Diddy likes this.
    07-06-2022 06:12 AM
  25. IsbellDL's Avatar
    Well, I can now confirm that the USB-C port was NOT the source of my problem. I received it in the mail and installed it today. I do like having a phone that I can open up with just a T5, & work inside with a Phillips 00. Sadly, it looks like software (or maybe even worse hardware?). I guess I'll keep troubleshooting and see if I can solve it. On the upside, USB ports don't fall off anymore, and I can still charge it if I restart with it plugged in.
    B. Diddy likes this.
    07-15-2022 03:56 PM
63 123

Similar Threads

  1. Replies: 8
    Last Post: 08-11-2021, 06:03 PM
  2. How is your phone with a low signal?
    By donebrasko in forum Samsung Galaxy S21 & S21+ & S21 Ultra
    Replies: 10
    Last Post: 06-24-2021, 08:17 AM
  3. tab s5e charging icon
    By edgie70 in forum Samsung Galaxy Tab S5e
    Replies: 1
    Last Post: 06-21-2021, 03:11 PM
  4. Mac address filtering mobile hotspot Android 11
    By dekatch in forum Ask a Question
    Replies: 5
    Last Post: 06-21-2021, 11:01 AM
  5. The "Your Devices" page of "My Activity" in Google
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 06-20-2021, 05:56 PM