1. AC Question's Avatar
    First of all i tried to go into recovery mode by using the regular method of pressing all three keys together; the screen appears for asking to reboot press volume up or down to cancel. The problem comes here i press volume up button after releasing rest buttons. and it does not go through instead it keeps restarting again and again and showing me galaxy s3 logo every time. I tried everything but its not working at all my phone is not going into recovery mode as per standard instructions. Please help me out.
    09-26-2014 04:52 PM
  2. belodion's Avatar
    If it's of any consolation, I find it difficult to enter Recovery Mode on my Nexus 5....it tends to just keep restarting. It may take half a dozen or more attempts before I can get it to work. Since there's seldom any need to enter Recovery, this is hardly a problem. Perhaps your device is simply difficult in the same way?

    Posted via Android Central App
    09-26-2014 05:14 PM

Similar Threads

  1. I think I dropped my phone one to many times
    By Denisew 1972 in forum Samsung Galaxy S3
    Replies: 4
    Last Post: 09-28-2014, 11:46 AM
  2. Replies: 1
    Last Post: 09-27-2014, 12:34 AM
  3. Replies: 1
    Last Post: 09-26-2014, 05:01 PM
  4. Replies: 0
    Last Post: 09-26-2014, 04:42 PM
  5. Replies: 0
    Last Post: 09-26-2014, 04:39 PM